Smartthings settings migration issues

Has anyone else had the same issues as me with the app transfer.

The banner never appeared to transfer the settings, despite raising a support request over two months ago and chasing it most weeks no one ever got back to me.

Now the classic app has stopped working and I can’t access any of my setting now.

Finally got a response from support, they suggested I had to many routines and that I should delete some and see if the banner (in the closed down app) appeared then?

This change over is a complete shambles from top to bottom?

Can you login to the Classic to view the routines or SHM/ShM custom rules? Login using new to SmartThings and with your Samsung account.

Users have been having multiple issues with the migration. Devices that don’t show up, routines/custom rules that do not convert properly. Presence not working, etc.

Best advice would be to manually set up stuff in the new app and remove from the Classic if you can. Start with SHM and any custom rules —> install STHM in the new app. Change the custom rules to automations and scenes in the new app. Once done, remove the rules in the Classic and remove SHM.

Install smart lock guest access in the new app. Then migrate all your routines over to automations and scenes and remove the old routines in the Classic app. And set up location services if you use that.

Not going to be fun.

@rboy wrote a faq page somewhere on switching to the new app. Hopefully he will post the link for you :slight_smile:

1 Like

I can’t access the old app at all now, it forced me to log out and won’t let me login again.

Not sure this product is really fit for purpose as a consumer product based on my recent experience.

I think I have days of work to try and sort this shambles out !

It’s best not to use the Migration button as it sometimes creates more issues than it resolves. As one of the staff members at ST had suggested, all the migrate button does is:

  1. Delete your Routines from the Classic app and converts them to Automations and Scenes in the new app
  2. Deletes SHM and Smart Locks from the Classic app and creates STHM and Guest Locks in the new app

If you can do those 2 steps by yourself, you’ll save yourself a bunch of issues. Since you don’t have access to the Classic App you can still do the above 2 from the IDE

  1. Open the IDE (
  2. Click on My Locations
  3. Click on SmartApps to the right of your location name
  4. Look under Hello Home and you’ll see all your Routines, click on Edit and then click on Uninstall next to each Routine name
  5. On the same page look for Smart Locks and Smart Home Monitor (SHM), click on Uninstall

Once that’s done head over the new ST app and you should see all your SmartApp and devices already there. The SmartApps can be accessed by clicking on the Hamburger Menu on the top right and clicking SmartApps.
From the menu you can recreate your Automations and Scenes to replace your Routines and install SmartThings Home Monitor (STHM) and Guest Locks or any other apps you want.

Here are two FAQ posts which talk about migration to the new app:

So all the blurb about this being a seamless switch over using the transfer tool was utter rubbish then?

Not really, it works for many users however some users have faced issues and some of the issues created can result in a lot more effort to fix the new problems than doing it manually. Nothing’s perfect, so you’ve got options :slight_smile:

I have to admit I have found it a very poor experience, the banner never appeared and having a ticket on the issue for over two months without a response was very poor, certainly put me off Samsung products going forward.

Well its good to know the new app hasn’t changed since I last programmed it two years ago, buggy as hell and after setting up a key fob (working fine in the old app) it no longer works now. How much do I regret thinking if it has Samsung on the box I could rely on it.

Anyone been successful in getting a “Aeon Key Fob” working in the new app, was working fine in the old app.

The device handler doesn’t seem to distinguish which button is being pressed, so despite mapping the buttons to actions nothing happens. Pretty sure it was like that 2 years ago when I tried the new app?