SmartThings Power Outlet Won't Connect

I purchased the SmartThings Home Monitoring Starter Kit this weekend and was able to connect all of the sensors to the Hub just fine, but I have not been able to get the power outlet to connect. When I try to Add a Thing from the mobile app, it just spins and spins and never finds the power outlet. I have the outlet about 2 feet from the Hub so I’m not sure what the problem is. I have also already tried resetting the power outlet multiple times by holding in the button while plugging it in. Any suggestions?

what is the specific outlet you are trying to pair? Brand/ model would help trouble-shoot

The Samsung SmartThings Outlet. This is the one that is packaged with the Samsung SmartThings Home Monitoring Kit.

  1. have you exited out of the marketplace and just checked to see if it was added to the devices (even though it kept spinning)?
    On occassion I have had a device add when I checked it was actually added and then needs to be “named” and smart apps have been added.

  2. have you exited re entered the marketplace and tried a couple of times?

  3. You may want to reset (even though you have not added)

How to reset the Samsung SmartThings Outlet

If the Samsung SmartThings Outlet didn’t connect to the Hub when you plugged it in, reset and connect the device manually.

Remove the Outlet from the wall receptacle
Press and hold the Outlet’s Connect button while plugging the device back into the wall
As soon as the LED turns on, quickly release the button
From the SmartThings app, tap My Home
Under Things, tap Add a Thing at the bottom of your Things list
The app will say Looking for devices…
Once the app shows a device has been found, follow the configuration steps above

Try these few things and see if you can get it paired.


Wouldn’t you know it, resetting it again using your instructions worked. I think the key this time is I did not hold the button in nearly as long after plugging it in (as soon as the LED came on I released the button). Previously I was holding the button in for a few seconds before releasing it

Thanks for the help.

Anytime ! Glad you got it working :slight_smile:

Hello, jumping in here as i’m having trouble connecting the same smartthings outlet plug to the hub. i’ve tried all the above but no luck. I’ve managed to pair other devices.
This is rather frustrating!

any ideas welcome?