Help: Unable to connect Samsung SmartThings Outlet

Yes, before anyone says it, I know there’s topics like this in here already. I’ve read quite a few of them and neither the steps suggested nor the specifics match my case very well :disappointed:

The summary is, I have one hub and 37 devices happily connected to the hub. 8 of those devices are Samsung SmartThings Outlets. I picked up 6 more of these outlets from Amazon and went to connect them today. Out of the 6, I was only able to connect 2 of them. The other 4 seem totally invisible to my hub.

Things I’ve tried:

  1. Specific to the outlet, putting it in join mode manually (blinky light mode)
  2. From the app, repairing the z-wave network (multiple times)
  3. Holding the little reset button on the back of the hub for 10 seconds
  4. Removing a previously joined Outlet, then trying to re-add it (in the hopes that i somehow just got a batch of bad outlets). Yeah turns out I couldn’t re-add it either so now I’m down an outlet. :sob:
  5. Adding a completely new device (Samsung SmartThings Motion Sensor) and it joined just fine!
  6. To rule out distance, tried joining new outlets a few feet away from the hub. No dice there either.

So based on #4 and #5 above, it would seem that the problem is with adding outlets somehow. This doesn’t make much sense to me though.

I’ve stared at the Live Logs for a while and have been unable to see anything useful… though that just might be out of my own ignorance.

Has anyone had problems like this and know how to solve them? I’m currently out of ideas :cry:

Instead of Live Logging… For join activities you should be looking at the Hub Events (under Location, My Hubs, or around there).

If it’s consistently the same brand of outlet, then I’d suspect a problem with the DTH that SmartThings is attempting to assign.

If it is a type that runs locally in Hub V2, then I’d suspect local corruption… You can maybe rules this out by copying the DTH code onto a new custom DTH with just a new name and self-publish.

Thanks for the idea. So I’ve read most of the docs on DTH’s and don’t see any references to how one would go about copying the exact DTH code that is being assigned. I’ve found templates that are similar I assume but I would expect there to be a way for me to take an existing device and copy the DTH that is being used.

Also, let’s say that I do have local corruption. What then? Is there a way to nuke the local DTH it’s using and have it download / create a fresh copy?

I’ve tried to join other devices and they all join fine but any new Outlets, even if they were previously joined, fail to join now.

Wrong assumption (unfortunately). There’s no way to reference the exact DTH that SmartThings may be using. You can only use the templates or search the SmartThings GitHub and find what you hope is the same code. Of course, this is only for diagnostic purposes, so it doesn’t have to be exact … just compatible. https://github.com/SmartThingsCommunity/SmartThingsPublic

We “customers” don’t get any such control over own Hubs. You’ll have to contact Support@SmartThings.com who can perhaps do diagnostics and possibly they have a way to force a hub refresh of some sort.

I definitely recommend reaching out to support. They’ll do their best to take care of you!

The outlets can be stubborn sometimes. Does it help plug it in with the button held down (while the Hub is searching for devices), then hit the button a few times once the LED blinks 3 times?

Have you tried doing a full power down of the Hub for a few minutes?

2 Likes

The SmartThings plugs are zigbee, not Z wave, so there’s no point in running any of the zwave utilities, they won’t apply.

I agree that your best bet at this point is to contact support. It’s possible you just got a bad device, it can happen. But support will be able to see some things in their side that can help troubleshoot.

1 Like

Thanks guys. To answer the above questions:

Yes. Per #1 at the start of this post, that didn’t help at all.

Actually no, I only tried pressing and holding the reset button on the back for a bit as well as clicking the reboot button in the portal. I’ll pull the batteries and unplug it for a bit to see if that helps. Good idea.

Yeah I thought this too. I have tried 5 of them at this point (one that was even previously joined) and they now all fail to join. It’s crazy too because I can join any other device I try and I have 7 or 8 other outlets identical to these new ones that are already joined.

I’ll round back to this thread after I talk to support to let you guys know what they said. First I’m off to pull the plug and batteries out of the hub.

1 Like

Leave it off power for at least 15 minutes while leaving all the other devices on power. That will force A zigbee “heal” once the hub comes back online. It may take a while for all the changes to propagate, but you should see improvement by the next day.

Next obvious question – – is there a range issue here? How far are the new sensors from the hub or from the nearest mains-powered (Not battery powered) zigbee device? Remember that zwave repeats only for Z wave and zigbee repeats only for zigbee, so you only want to consider plug-in or wired in zigbee devices for this. And don’t consider lightbulbs. So typically pocket sockets, in wall receptacles, light switches, and in wall relays.

In other words, if you put the new sensors about 20 feet away from the hub Do they work then?

(I’m tired now so I don’t want to go into technical details, but don’t put them right next to the hub and don’t put them with in 3 m of a Wi-Fi router or Wi-Fi access point.)

Super useful JD thank you. Will give that a try.

As for range issues per #6 above I tried to rule that out by trying to join and fail in multiple locations from about 6 feet to about 20 feet away from the Hub.

Lastly the Hub is no where near my WiFi AP.

1 Like

It’s somewhere near your Wi-Fi router, though, right? Because they both plug into your main router.

The point is just that wifi can drown out zigbee, so it helps to have some space between the transmitters.

No. I’m well aware that any WiFi AP (standalone or router) can cause interference so I’ve placed the Hub far away from any of that.

So I totally powered down the Hub for an hour, plugged it all back in, waited an additional 12 hours. Still no dice today. I’ll reach out to support and see if they can solve my issue.

1 Like

Gave them a call. Answered all their question before they could ask them. Thanks guys! Now I’m being transferred to Tier 2. On hold. This should be fun.

FIXED! Turns out it was user error!

I was holding down the button too long when doing the reset / join on the outlets. Specifically if you hold down the reset / toggle button, plug in the device, and keep the button pushed a second too long then the device light will start blinking. I mistook blinking as successfully entering JOIN mode. Turns out this mode is “Don’t Join” mode and should be avoided.

Thanks for all the help on this guys. The upside to this is that I’ve learned a whole lot about DTH’s and am working on writing my own.

2 Likes

I’ve successfully added a SmartThings outlet to the hub, it works, then I’ve taken it outside about 40 metres away, and it’s now out of range, I’ve done a Zigbee repair, should I wait 24 hours? Or if its out of range now, which seems strange, it won’t come back online at all?

I know this was 2 years ago, but could you explain what the fix was? My outlet just flashes blue nonstop, and I can’t get it to pair to the hub.

Would love an answer as well, my new Samsung v2 hub and outlet doesn’t want to pair as well, I tried all the steps above. I’m now waiting for support to contact me. I’m wondering if it’s a bad batch of outlets. :slight_smile:

To be clear, the scenario I was facing was one where I needed to rejoin a V1 SmartThings outlet. I think at this point they are on the 3rd of 4th generation so YMMV. In any case with the V1, what I was saying was that the process to enter join mode was:

  1. Hold down the power button
  2. Plug in the device with button held down
  3. Immediately let go

Before my problem was that I was holding the button far too long after plugging it in which put it in some sorta error state. Not sure if this is what you’re asking but that was the solution I was trying to explain back then.

Thank you for the advice, it turns out I need to power off the hub and take the batteries out a few times… then it finally picked up the outlet and some new sensors I purchased too.