SmartThings on Samsung S21 UK can't download SmartThings Find and new firmware for SmartTag+

Based in England. Have a Samsung S21.

Just bought a Samsung SmartTag+. So installed the SmartThings app from the Galaxy Store.

Noticed the SmartThings Find card on the Life tab by default. Tapped it but told to download the SmartThings Find. Said yes, then the card stuck at “Downloading…” forever.

Thought I needed to connect the tag first. So took out the tag, activated, the app found it - good, went through the steps and the tag appeared on my Devices list and shown as Connected.

Also I was told there is a new firmware to download. Tap it the SmartTag+ tile stuck at Downloading - 0%. And I got a message saying “We’re having trouble connecting.”

Tried with the wifi at work, my mobile data, my home wifi, my wife’s mobile data with her sim card.

None worked. Reckon the issue can’t be at my side.

The tag is now useless as I still can’t download the SmartThings Find addon. Any ideas?

1 Like

I think you’ll probably get the quickest help by going to the official mobile phone support for the UK. This forum was set up a number of years ago so that customers could help other customers with the home automation platform, and there aren’t Samsung employees officially helping here. This is a great place for ideas and suggestions on projects, but we don’t have access to the kind of account information that’s often needed for troubleshooting.

Anyway, if you haven’t already tried it, you can reach official support for the UK through the following:

1 Like

Ah my mistake then. Thanks a lot. I thought this is their support forum. Thanks.

1 Like

hi !! had you fix the problem ? i have the same problem i just order one today i have same problem

can you let me know
thanks

No not at all. Wasted almost an hour with Samsung tech support who at the end suggested me to speak directly with Devs using Samsung Members app. Not bothered and will try again in a month or so.

1 Like

Same issue, SmartThings Find & smart tag+ controller isn’t downloading. Doesn’t go past 0% and then comes up with network connection error. anyone found a fix?
Thanks

Just tried again. All good now.

2 Likes

Yh, mine works too. Got an email from SmartThings Support they found the issue and fixed it. Thanks

1 Like