SmartThings Location History Issue - SmartTag2 - A network or server error occurred. Try Again later

Hi mates,
Hoping all is well.
Would you mind help me with my new smarttag2 units? I’ve bought set of 4, but are having the following issues:

  • When going into location history - “A network or server error occurred. Try Again later.”
  • The unit cannot be found in the map other than near my S23 phone. I’ve given it to my daughter for a city (Melbourne) field trip and we attached it to her backpack, she has S20 phone, but the map is still at home and becomes offline for the whole day until she comes home.
    I’ve uninstalled, reinstalled the smarting’s app (android), cleared it cache and data, reactivated locations, etc, but didn’t fixed anything.
    Thanks in advance for your help.
    Kind regards,
    Victor
1 Like

Make sure you have shared the smarttag2 correctly.
You have to allow sharing on both phones.
If you can’t get it to work remove the smarttag2 and setup again.

1 Like

So it sounds like the tag is paired your S23 via the SmartThings app.

What about your daughter’s S20? Is her phone configured for SmartThings or is she just carrying ‘your’ tag? If she is plumbed into SmartThings then make sure she has enabled sharing for the tag in the Find app as @Andrew_Bartlett has advised. Otherwise it could be that her phone is connected to the tag (meaning the tag doesn’t consider itself lost) but not reporting it’s location. I accept that ‘could be’ is doing a lot of heavy lifting there - tags aren’t exactly well documented.

In the ‘Find My Mobile’ settings on her phone is ‘Offline finding’ enabled? That is the setting that should let her phone detect and report the location of nearby tags that haven’t been connected to for a while and consider themselves lost. One would hope there are lots of other Samsung phones around doing exactly the same but hers will be ideally positioned as long as it is online with Android location tracking enabled.

1 Like

Hey mates @Andrew_Bartlett and @orangebucket ,

Many thanks for sharing your guides, I’ll look into it and will keep you posted.

Probably my understanding how this device work is like I’m treating it with some kind of a GPS device.

You are correct that those 4 smarttags2 are only setup to my S23 phone. I’ve given it to my daughter, thinking, that it will work similar to a lost bag/luggage, and it will ping to closest galaxy devices around it (Melbourne CBD), and that I’ll get the location through it.

Same thing happened when I just gave the other unit and we’ve put it in my wife’s car (similar scenario to the backpack). Both smarttag2’s devices initial location is our home; and when they reach their destinations, the location of the tags were still at at home after several hours away until they’ve come back.

For the other 2 units, it is with me; my car and my car key; the location will update whenever I go (and I reckon that how it should work); but whenever I select the “location history”, that “network or server error” will popped up. That goes to all 4 of the units too.

I’ve tried also reaching out samsung smartthings customer support but was told to reach out the Australian samsung support.

Thanks mates for your time reading this, and will keep you posted on updates.

Cheers!

Victor

1 Like

Hi Victor,

I am facing the exact same issue.
I tried everything, but nothing helped so far.

Please update me, in case you get it solved…

Thanks and best regards,
Tim

Hi mates, Tim ,

I’ve followed above shared possible solutions from our mates @Andrew_Bartlett and @orangebucket , but no luck, and find that possible fault was the region settings - because even thou me and my kid’s phones are Australia region, she couldn’t also connect to smarttag2 device (that’s the hint).

And yesterday, I’ve received response from smartthings Australia support, and followed the instructions, and so far it works for me! :blush:

Here it is, hope this helps to everyone having the same issues:

"Currently the device information and user information are different region due to changing country.

If you change the country information in Samsung Account, this error occurs.

In this case, you need to “leave SmartThings” in SmartThings settings menu.

Then re-signup in SmartThings after a few hours, as we need time to delete all your data."

*note - you may need to re-add all your devices to smartthings and also I’ve reset my smarttag2 devices by removing the battery and reinserting, and rejoined again.

Cheers mates!

3 Likes

Exact same issue. Im getting the same error. It is frustrating. Not workign the way it should be.

@ViCKo what do you mean by leave smarthings?
Do you mean the phone should be decoupled to smarthings ?

You’ll need to contact SmartThings tech support to let your account sync your current subscribed region vs their region records with them. Once you’ve received their confirmation (if that’s the case your region’s not the same), they will advise you to logout, uninstall, and start again with SmartThings app and account.