Smarttag 2 installation issues

Hi, I purchased 4 Smarttag 2 devices, the first one installed easy peasy and then the next 3 is detected but does not install, its stuck at “Getting everything ready” on my S23+. I have tried this by scanning the QR code and the detection method and does the same thing. Anyone with similar issues and solutions?

I can’t speak to the reason you’re not getting them connected, but I have been able to connect all of mine to my S23+. In two cases, the initial connection required fresh batteries, as in new. After connection, they work without error.

Thanks Dan, I uninstalled and reinstalled the app this morning and then presto, they all work

I identified a scenario which seems to make the tag unconnectable. Apology, I don’t have enough credits to create a new post.

Here’s the scenario:
I already had a Samsung Account setup withing the SmartThings app on an iPhone, where I have multiple Samsung TVs and Soundbar devices added. Later I purchased a Galaxy S20+ phone which came pre-installed with the SmartThings app. Unknowingly, to myself another Samsung account was automatically created on that Galaxy 20+ phone using my Google account credentials. I initially connected the SmartTag to that Galaxy S20+ phone, where everything went smooth. When I opened the SmartThings app, I noticed the tag was listed as one of my devices but none of the Samsung TVs and Soundbar devices were showing. That’s when I noticed I was signed in under a different auto created Samsung account on the S20+. I therefore, tried to login into the SmartThings app with the same account I have on the iPhone SmartThings app. The App would not allow me to login using a different account. To do so, the app forced me to go through steps to “Delete” the auto created Samsung account on the S20+. After deleting that Samsung account, I could then log into the app with my original Samsung account. Ok, great! Now I could view the Samsung TVs and Soundbars devices within the SmartThings app on the S20+ phone. Now to go back and connect the tag to that same account. I went through the steps to “Set tag back to factory default”, chirping sounds observed indicating success. Tag would not connect after factory reset, like the 1st time it did of being auto recognized when being near the S20+. Not quite factory default then is it? I therefore attempted to perform the manual connection of the tag to the SmartThings app by scanning the QR code on the box. Each attempt I was stuck on the screen which said “Press the button on the tag”, but no response and no messages to guide the user something was wrong. I spent hours trying to connect this tag after the 1st time was done in 2 minutes. The only thing I could guess what may have happened, was the tag was now locked to the auto created Samsung account which was now deleted since the SmartThings app forced me to delete that account, so I could log into the SmartThings app with my original account. Apparently, I may have missed the part where I needed to remove the device from the account it was originally connected but now I can no longer perform that task because the account has been deleted where this particular tag seems to no longer be able to connected to the S20+ phone. After that ordeal, I was able to connect 3 other tags easily once I was logged into my original intended Samsung account within the SmartThings app.