SmartThings Find won't open on one S21 Ultra, but works on another

I have an S21 Ultra 5G.
My partner also has a S21 Ultra 5G.

SmartThings Find works with one phone but not with the other.

I added a SmartTag to my account.
I could track it via the web-app, but not via SmartThings Find, as SmartThings Find refuses to open on my phone.
It just hangs on the loading screen forever (“Locate your devices anytime, anywhere”), never showing me the map.

I removed the SmartTag from my account and added it to my partner’s account.
SmartThings Find opens on her phone and she can track the tag via the app.
She shared the tag with my via the app.
It appears in my device-list in SmartThings app, but with “Agreement required” under it.
When I tap it, SmartThings Find tries to open but gets stuck on the same loading screen as before.

I suspect that the “Agreement required” message is a big clue to what the problem is, but there’s no extra error information to help me figure the rest out.

Both phones are kept up-to-date. I’ve tried removing + reinstalling Find. I’ve tried removing + reinstalling SmartThings, and rebooting before re-installing it. We’ve tried removing the device from either account, and re-adding it. The Find app just doesn’t want to open on my S21 Ultra, but does on hers.

I’ve seen people on Reddit with similar issues, saying that Samsung support told them to nuke their phone (master reset), and that after all the effort of restoring stuff afterwards, it still didn’t fix the issue.

Has anyone had a similar issue and actually found a working solution?

Possibly related(?) issue:
My phone also has an occasional / intermittent issue with Bluetooth audio to the car (2015 Toyota Avensis) - some days the audio keeps dropping every 1-2 seconds.
I mostly solved this by disabling the hardware offloading for bluetooth in advanced/dev settings, although the issue still occurs occasionally (rarely now though).
This issue hasn’t occurred at all with my partner’s phone and the same car.

OK… throwing this out there but probably will not resolve the issue:

  • remove Find
  • remove ST app
  • you can reboot phone but probably not needed
  • reinstall ST app from Galaxy Store (or Google Play Store if that version does not work)

again,providing the suggestion but I have no clue if it will resolve the issue.

1 Like