SmartThings not working on new phone


#1

Have had SmartThings working for a couple of years. Just got a new phone (Samsung Galaxy Note 9). This came with the new SmartThings app pre-installed. It acted as if I was a new user and didn’t recognize the hub, even after logging in. Installed the classic app, now it’s doing the same thing.

Cleared all data/cache and force stopped the apps. Tried classic app only, and it’s doing the same thing. If I try to enter the original welcome code, it tells me that the code is invalid since it’s already registered.

SmartThings is becoming quite frustrating, such a simple thing as logging into your account and importing hubs/devices.

Anyone have any suggestions before I throw this thing in the garbage?


(jkp) #2

Before you got the new phone, were you using a SmartThings account or Samsung account to login to your app?


#4

Smartthings account.


#5

I’m sure the problem isn’t the Note 9, it’s got something’s to do with migrating to a new phone. I mentioned the Note 9 because it came preloaded with the new app.


(jkp) #6

You should contact ST support and see if they can migrate your ST account to your Samsung account that is being used on the new phone :slight_smile:

https://support.smartthings.com

You can try logging out of the Classic app, choose new user and select SmartThings to login. Not sure it that will work or not, but worth trying.


#7

Thanks for the info. The classic app doesn’t provide the opportunity to use a different account. I even tried deleting the Samsung account, the only option was to log back into it.

Very frustrating for something that should be a simple process.


(Jacqueline Flores) #8

Before setup smart things, create smart things account. After creating account, setup it on your smart phone following step by step instructions.