Please help: changed to Samsung account, now app doesn't work


(John Lacour) #1

Today I was asked to change my account to the Samsung account. Now every time I use the app on my phone or my tablet I cannot connect to the hub anymore. Any help is appreciated. If I go to my computer I can get into SmartThings desktop and I can see the Hub and my devices. But on the app on my phone it does not see the Hub anymore. I tried to uninstall redo my password nothing seems to work


(jkp) #2

use the ST Classic app, logout then login but choose new user and select samsung account when prompted.


(John Lacour) #3

I tried that I’m using a Samsung phone and it just keeps logging me back in with my new Samsung account and the app cannot find my hub


(jkp) #4

did you create a different samsung account from the one you are using on your phone? Have you checked to see if you have two home locations in IDE?


(John Lacour) #5

I only have one Samsung account . It seems to have gotten worse now the IDE can’t even find my hub


(jkp) #6

install the SmartThings (Samsung Connect) app and see if things show


(John Lacour) #7

Tried. That Also no good


(John Lacour) #8

Appreciate the help I lost everything The Hub is not reset. I got to put all my stuff in


(jkp) #9

contact ST support and let them resolve the issue - https://support.smartthings.com


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #10

I’ve read many times that the Account migration can take up to a few hours to complete … there’s some sort of background synchronizing that takes place. This might be the situation you are encountering.

Be sure to monitor the My Locations page under https://account.SmartThings.com

  • If multiple Locations show up, drill down and carefully figure out which is the correct one with your Hub and Things and edit it to set it to “default”. Only then can you safely delete the other one(s).

It doesn’t hurt to contact support, but it is likely unnecessary.


(John Lacour) #11

Thanks for your help I did send an email to support. But by now my Hub got reset I lost all my stuff so I’ve been busy putting everything back in what a pain in the butt.


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #12

This is not supposed to happen or be required. Real shame.

And @HA_fanatic thinks there’s no major problems with Account migration.


(Bob Kerr) #13

Ha, ha, ha. I didn’t generalize my positive experience. I even said that I hope most people will have the same experience as mine. In his opening @John_Lacour said he was able to see his hub and devices in ide, so his location got messed up, which support hopefully can fix. I hope that he didn’t loose all of his “stuff” in his own attempt to fix things. I have done that before, when trying to “fix stuff” I ended up permanently breaking it. I really hope support will sort things out for @John_Lacour.


(John Lacour) #14

Yep I kept messing around with it and I ended up losing everything. Then I was able to see my hub and there was nothing in it so I’ve been busy for hours putting everything back in still not finished. I really appreciate everybody responding and trying to help me


(Bob Kerr) #15

Sorry man. I’ve been there done that. Couple of times I was lucky and support was able to put it back together for me. I hope they will get you squared away. At this point, I would watch the chat to go online and work with them. If you are lucky, you get a great agent who can save the day.


(John Lacour) #16

Thanks I still have two locations in here one is John’s house which is the one they screwed me up on and it only shows my Samsung TVs that’s what I was left with when it when I changed my account. The other one is the one I renamed John this one. That’s the new one where I’m installing everything I’m afraid to delete the old one.


(Bob Kerr) #17

That seems unrealistic. My migration (150+ devices) took no more than 2 minutes and I have a lot of custom apps and drivers. @vlad might be able to confirm, if he ever gets a minute to chime in…


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #19

(vlad) #20

My understanding is that the migration process should complete quickly (a few minutes, not hours). It may be worth opening a support ticket for that case to at least report the delay.

OP, apologies that you ran into this issue, it sounds like you are working through rebuilding your system. Please do let know support what happened and when so they can look into logs as if hubs are getting reset, the team working on migrations needs to look into it.


(John Lacour) #21

When I was having a problem on Sunday I did contact them email. When I did find my Hub again there was nothing in there. I have not received a response from them yet