SmartThings not showing up in Location Services?

Just getting started setting up SmartThings. I’ve installed it on my iPhone and things seem to be working fine except the app doesn’t show up in the Location Services page, so Geofencing doesn’t work.

I’ve tried deleting/re-installing and re-establishing my home location, neither of those worked.
It does show up in Notification Center.
Plenty of other apps do show up in Location Services.

Is there some toggle in the app I’m missing to enable this?

iPhone 6S Plus, iOS 10.2.1

The one caveat is that it’s a company phone, so it’s got their policies installed - I’ve got tons of other apps that are working fine with Location Services, so (unless they’re specifically blocking SmartThings?!) I dont think that’s the issue.

Doesn’t show up on mine either. IPhone 7, 10.2.1. I’m not sure it ever did to be honest. Hasn’t stopped presence sensing from working for me however. I would recommend just setting up the phone as a presence sensor and then experiment with leaving and see if it detects that properly.

1 Like

That was the ticket - I had to enable the phone as a Presence Sensor. Now it’s visible in the Location Services page.