Smartthings not seeing Ring Video Doorbell Pro as Doorbell

I had some issues where I had to resync by Ring account with the Smartthings and rebuild my automations. When I did, Smartthings only sees my Ring Video Doorbell Pro’s motion sensor. I don’t have the option to create an automation for when the button is pressed. I’ve tried searching and haven’t seemed to find someone else with this same issue.

I’ve tried resyncing the account several times. I’ve tried re-adding the device to ST multiple times. Any advise would be appreciated.

I had an automation that would notify me if my Ring battery dropped below a certain percent. I tried to rename it and received an error, so I deleted and went to recreate it. I found that ‘motion’ is now the only variable available with the Ring when creating an automation. Not sure if my old automation would have ever fired or not anymore. I was able to create a ‘Smart Lighting’ automation that would use a Ring button press, so I don’t know if it’s a fault in the new app automations for excluding the button, battery, etc or in Smart Lighting for including the button.