Smartthings no longer an option in Harmony App? (May 2019)

I currently have 3 Harmony hubs and I have never had this issue before.

I went to add add a device in my Harmony app to one of my hubs and Smartthings disappeared off of the Home Control list. I attempted before and it was there but after I logged into Smartthings, selected the devices in Smartthings I wanted to add, I received some kind of an error.

I exited out and back into the Harmony app and now, when trying to add a device again, Smartthings is gone under Home Control.

How do I get it back?

Here’s a picture.

1 Like

I was able to add Smartthings device using the Harmony Mac desktop software, but Smartthings still doesn’t come up in the Harmony app under Home Control when trying to add a device.

Anyone know why Smartthings would disappear from the Harmony app?

Are you on the same LAN?

Yes, I’ve added many Smartthings devices to various Harmony hubs, never had an issue.

All the sudden, Smartthings disappeared off of the Home Control list of options to choose from when adding a device.

I can still Control Smartthings devices through Harmony, I just can’t add any Smartthings devices to Harmony because Smartthings is not showing up under Home Control list of devices to add.

I would get in touch with Harmony support and see what they say.

Just got done spending 20 minutes chatting with them trying to explain what is going on and they just weren’t comprehending the issue.

Then I got disconnected… :rage:


Still working for me, and I haven’t seen anyone else report a problem.

But I only have one harmony hub.

What I don’t understand is all these other Home Control devices that I don’t even have are there to choose from.

Why on earth would the Smartthings option disappear?

I just went in and tried to add a SmartThings device to the hub that doesn’t have any smart things devices connected to it and smart things does show up in the list of home controls items to add.

So basically the hubs that I already have SmartThings devices connected to are not showing smart things in the home control list of devices to add.

Missing for me as well. Just got a new TV and and apparently cannot add/remove ST devices any longer. But the previously setup devices are still controllable from the Harmony app/remote.

Only the Harmony desktop software is working for me. You will have to plug in your remote via usb.

I see it here. Maybe uninstall and reinstall the app

It probably thinks you already added it as a device and therefore you can’t add it again.

If it shows up under Devices then the Harmony app thinks it’s already been adds. Just a thought. May not be the case

1 Like

It doesn’t show up if you already enabled SmartThings. You have to goto edit devices and then click on one of the devices then re-login:


Thank you, I just figured this out right before you posted!

Thanks for the help :smile:


Hi Guys,

I’ve the same issue: couldnt see Smartthings in home control.
In my devices list there’s also no smartthings.
May i know how to resolve this?
Thank you!


I have the same issue. I had Harmony hub added to Smartthings, but if I toggle an activity on the remote, Smartthings scenes would be triggered about a minute later. So I wanted to add Smartthings as home control in harmony hub, so the remote it self does switch the lights. However, Smartthings never shows up in the harmony app. I even removed harmony hub from Smartthings, but it didn’t help.

I have a Smartthings V3.

Did you resolve the issue?

You can have the Harmony sequence turn on and off the harmony switch that ST uses. This makes it quicker instead of waiting for the sync.

Not sure what you mean? When harmony is switched on the remote, Smartthings doesn’t get updated (the switch in Smartthings) until it syncs with the harmony hub, which appears to be around a minute or so.

That’s why I wanted to add Smartthings in the harmony hub, so harmony uses Smartthings as “home control”, but like other people , Smartthings never appears as an option in harmony hub

Try to add Smartthings as a device, that’s the only way for me. Manufacturer = Smartthings. Product = Hub, then just sign in when promt.


OMG! This is just crazy… Why have Logitech/Harmony change it to work this way… :frowning:

That solved it. Smartthings is not located under Home Control anymore (for me at least), it is now under “Entertainment device” and as you said as I had to type:
Manufacturer = Smartthings
Product = Hub

You saved me alot of time, THANK YOU!