Smartthings newbie's difficulties - from Wink to Smartthings

Just decided to shutdown the Wink (great for last year years) for many z-wave zigbee, wi-fi,Bluetooth devices.
I own the smartthings hub v2 for years on shelf.
I downloaded the smartthings app , created an account.
the first difficulty was to add the hub. when I chose my hub to add , the app instantly crashed. Changed to the different phone (moto z4 on android 10) , same result, the app crashes when trying to add ST hub. choose another phone, the same result , app crashes when trying to add the hub. Tried another way, download “smartthings classic” to let me finally add the hub.
Second problem is to add a Thing.
Reset all my OSRAM LIGHTIFY bulbs, click to add. the app is running the searching devices, the hub green light is blinking , my bulbs all showed two flashes, it means they got paired. but the app keep looking for the devices, nothing found. re-did again and again, it is never able to add the any devices. Did my z-wave switch , same thing, the device showed it got paired, but nothing showed up in the app. the app just keeps forever to look for the devices… never able to find anything.

I cannot believe it is so difficult to add a device to the Smartthing.
Any helps ?

Have you reviewed the troubleshooting steps on the SmartThings Support site:

I also found these in the SmartThings Community:


Eventually, I did remove the hub , did a factory reset. The same happens, the Smartthings app did crash when I tried to add the hub.
Used the Smartthings classic app was able to re-add the hub v2 back
Now it works and be able to add things to hub.