Osram Lightify A19 RGB Bulb won't add thing

I have a smartthings v1 hub and the Osram Lightify A19 RGB Bulb but it won’t ever come up when trying to add a thing. I’ve tried everything on these forums from resetting the bulb and rebooting the hub, but nothing seems to work. I have 2 of these bulbs and neither are found. I have multiple other things that are paired to the hub fine. Could it be that these won’t pair with the V1 hub?

Complete re-edit… Sorry for the confusion… I was thinking of the Osram with the Philips Hub…

Did you already try going through the Marketplace/Light Bulb/?

Yes, tried the Marketplace and went directly to the correct bulb. It just keeps saying Looking for device but never finds it. Have rebooted the hub several times and reset each bulb several times. Still nothing.

Yay. Got it working. I emailed smartthings support and they recommended (among other things) to put the bulb within 3 feet of the hub when pairing. I hadn’t read this anywhere before. It worked right away for both bulbs. Hope someone else see’s this. I think smartthings should consider putting this detail at the link below:

Osram bulbs are different. Instead of having the lights on then searching for them, you need to have the lights off when you start searching. Then once hub is looking for them, then turn them on. Give them a few ( 10-20) seconds to see if they flash that they were found. If they do not flash that they were found turn them off for a couple seconds then turn them back on again. It seems ( to me anyways ) they only send out their handshake when first powered on.