SmartThings multipurpose sensor connecting as unknown

A few of my sensors stopped responding after the maintenance outage. I successfully deleted and re-paired the others, but have not been able to reconnect one multipurpose sensor.

I’ve followed the procedure for re-pairing, but it either does not respond (LED does not light up) or I see the amber light flash and it pairs as an unknown thing. The battery was near full charge before this happened and the sensor had been working reliably.

I would appreciate any thoughts!

Try this thread (this is a clickable link)

or it could just be a bad device, that happens. But I’m guessing it’s a failed pairing and I’m totally guessing that that’s caused by the other platform errors that people are seeing as discussed in the above thread.

Thanks JDRoberts. It couldn’t hurt to try restarting the hub just in case.

1 Like

Make sure you leave it off for at least 15 minutes. You want all the zigbee devices to panic when they realize the Coordinator is gone. That’s what will cause them to rebuild their address tables and complete a new handshake when the Coordinator comes back online.

Also, you still might have to reset and rediscover that one individual sensor, but wait until after you have rebooted the hub and it may work better.

1 Like

Also, make sure the device is not visible in the IDE (

If that doesn’t work. Support is your friend :smile:

The hub reboot didn’t produce any better results. Good to rule that out though.

Double checked that the sensor is not showing up in the IDE. Unfortunately, support auto-reply says it will be a while before I hear back due to high volume :frowning:

It looks like the only other option to repair my security system is to buy a new sensor? I’m disappointed in how buggy this system has turned out to be.

Try this…

Reset the sensor. If it is our you can find the reset procedures for all of our devices and some others that we don’t make, including how to do a z-wave exclude if it is a z-wave device, at

Then once it is reset and ready to be rejoined rejoin it. My hope is that it may add as a new device. :smile:

If that doesn’t work support is going to be your salvation :smile:

Thanks, I’ve tried this reset procedure many times. Sometimes I get the amber light, other times the LED does not light up at all. I either get no response in the app, or it adds it as “unknown thing” (device is the Samsung SmartThings multipurpose sensor).

I will wait for the response from Support. Is there any way to get a response from them faster? I am depending on SmartThings for my home security system and it won’t work properly without this sensor. It’s been down since the platform update :disappointed:

Did you get it sorted in the end? Im having the same problem with 2 of mine.

All the fixes I tried failed so I sent in the old sensor and was sent a replacement. However, since then, several other sensors malfunctioned and I’ve quit using my SmartThings system.

I hope you have better luck than I did!

I finally managed to get it working. Some has made a header for it works perfectly try it out.