HUB_DISCONNECTED or OFFLINE Status, but they still work, no forum fixes working

Hi all,

I had a power outage that lasted an hour or so a few days ago. Since then, my V2 hub has not “Reconnected” to some of the devices. I have restarted the hub (including removing batteries). I have restarted devices (remove power - be it batteries or the air gap switches). I have operated (changed status) on the devices. Nothing seems to work though.

The devices are random zigbee door sensors (some connect, some don’t, randomly), GE z-wave switches (again, some work, some don’t), and a samsung/smartthings smart plug as well.

Now the even stranger thing, all of these devices are still functional in the app and via voice commands on Alexa! I can command them, check the status by clicking into them, and smartthings continues to log the data in history on any of the devices. Automations continue working (such as SmartLighting automations).

What is happening here and how can I attempt to fix this? I’ve included a ton of screenshots to help diagnose.

This shows some examples, OFFLINE or HUB_DISCONNECTED but it still has recent activity and works in the app - besides showing offline in the app.

Here are a bunch of app screenshots. FYI, the Philips Hue (Lux) lights are not connected, so you can ignore those.

Have you tried rebooting the hub from IDE?

1 Like

You, sir, are a genius. I never knew that existed in the IDE, it worked like a charm, thank you!!!

I spoke too soon, it’s doing it again, on the same advises (mostly), some new ones are on the list though.

I tried another HUB RESTART, but no luck. Any other ideas?

Over time, it seems more and more devices are doing the same thing. Some of them are non-responsive properly now, not just on the main screen. Never seen this happen before, is the hub failing or something?

I have the same issue without the initial power outage. Multiple devices show unavailable and/or offline. I tried rebooting from IDE twice, I also rebooted the hub by disconnecting all wires and batteries for some time but nothing seemed to help. I even changed the batteries on sensors that were reporting 22%, nothing changed. I ended up asking support for help but now they don’t want to help without the list of devices not working. Any other suggestions?

if using the Classic app, try disabling device health. also report these issues to ST support

1 Like

Are the devices Zigbee? If so, this might help:

1 Like

Thanks @Brad_ST. Looks like all are zigbee devices and all point to my hub in the Next Hop field. Hoping support can help me further. Is there anyway to remap the zigbee mesh since rebooting didn’t work?

My understanding is that Zigbee mesh is fairly aggressively rebuilt. Meaning a node doesn’t have to be offline very long before self-healing is attempted. I’ve seen recommendations of powering off the hub for 20 minutes but in my experience powering it down for 2-5 minutes is usually sufficient.

Additionally, you can look at the device events in the IDE and look to see if there was a “mass disconnect” event. Look to see when the offline devices last reported offline. Do the times line up across devices? Also look to see if any devices are missing recent events entirely which is indicative of a device being offline for more than 7 days which usually means it needs the batteries replaced or to be reset/re-added.

1 Like

I contacted support, they recommened a power down w/ batteries removed for a few minutes. So far that is not helping. More and more devices are going offline, my entire zigbee network save for 2 sensors are offline and my Zwave are randomly offline.

I have added no new devices recently, will check my logs a bit more today in IDE and reply back to Support as well.

~12 hours after the power down noted above (including batteries removed, ~5 minutes completely offline), I checked the ST app again, and devices started reconnecting randomly. ~24 hours later, all devices have reconnected. So I actually think that was the fix at this point.

1 Like

Devices are once again randomly going offline. Same thing as before… anyone else??

It seems like a local range/interference issue. Of your 3 routing Zigbee devices, two of them haven’t been communicating with your network in at least the last 7 days and the other is having a hard time communicating based on the Metrics reported by the device including failed message transmissions and duplicate messages received.

Can you help explain a few things for me?

  1. What are routing Zigbee devices?
  2. What devices have this capability?
  3. These were all connected with no issues for years, did anything change in ST that could have caused this? The devices haven’t physically moved - the only thing is that I’ve added MORE devices 6 months ago… but again, to be working perfect for ~1 year+ and then all the sudden have these issues with no changes being made, seems odd…


#1 and #2 There are three Zigbee device types. The coordinator (your hub), routers (devices that repeat Zigbee traffic between each other and your hub), and end devices which do not route traffic. As a general rule of thumb, most devices with a constant power source will act as routers. That includes devices like light bulbs, wall switches, and outlets. Battery powered sensors like most motion and door sensors do not route traffic.

There are a few outliers to the routing rule, for example at least some Sengled bulbs do not act as routers even if they are constantly powered.

Say you only have 4 Zigbee devices and they all are end devices. The only path for those devices is directly to and from the hub. So if you had a motion sensor 50 feet from the hub and door sensor 30 feet from the hub, in both cases the devices would be communicating directly with the hub. But if you added a Zigbee outlet 25 feet from the hub and in between the hub and the motion sensor 50 feet away, now the motion sensor can repeat through the outlet which is effectively cutting the distance in half.

#3 There isn’t anything that has changed on the ST side recently that would explain these issues. Absolutely nothing has changed in your local environment? No new USB 3.0 devices? Your network equipment is exactly the same? You may drive yourself mad trying to figure out the cause but that doesn’t change the result which is that your Zigbee devices are not communicating well with your hub. My honest advice if you can’t easily identify the source of the issue is to focus on making things better instead.

1 Like

I should note that if your Zigbee device has rejoined recently that you can see what type of device it is in the IDE.

On the device page look for zigbeeNodeType in the data section and you will see ROUTER,

You can also now see the Zigbee route in the mesh network.

I didn’t add any other devices, but one thing I was thinking about - I did buy an NVIDIA SHIELD PRO (2019 version). I read that may have some smarthome abilities… is THAT interfiering? I haven’t enabled anything on it, but maybe it’s enabled by default? It sits right next to my SmartThings Hub V2…

I just ran into this issue after my hub was unplugged for several hours (I was moving furniture, including what it was sitting on). Turning “Secure mode” off on my hub seemed to do the trick. Once everything was reconnected, I turned “Secure mode” back on.

This is the description of “Secure mode”:

Improve the security of your network by preventing disconnected Zigbee devices from reconnecting to the hub automatically. If a device disconnects or becomes unresponsive, you’ll need to manually reset it and add it to the hub again.

I’ve got insecure rejoin enabled, and this still plagues me every day. It seems to happen every evening. The daytime everything works fine. It happens nearly every day at this point though.