Smartthings multi sensor won't reset - led goes red but not discovered

Hi everyone - have had a new smartthing system shipped from amazon uk a few weeks ago. Most things have worked fine, however one multi-purpose sensor has been going offline every night (also checkinterval is 7260), requiring battery re-insertion. Today it has been going offline every few mins, so I decided to remove it from system, and do a proper reset.

As per support, even though I have the latest sensor, I need to follow the 2015 reset process from here
Problem is when i try to reset it while inserting battery, the led does not go blue, but goes red and it never gets discovered by hub!

The led going red seems to indicate I need to follow the latest process here but simply pressing the reset button without removing-reinserting battery does nothing to the led and not discovered either!

Any hints?

PS - my sensor shipped with some battery branded LIXING - even though label underneath says use panasonic or duracell only! I tried panasonic battery from another sensor but that did not help either!

1 Like