Smartthings Lutron something went wrong reinstall app

Just bought Lutron bridge for my Caseta switches and Smartthings to move from Wink. Was able to pair switches to Lutron Bridhe however when I go to smartthings iOS app and tried to add Lutron it throws me - something went wrong. Please reinstall the app. It doesn’t even show me Lutron login page to connect account. Please help

Go to menu (3 bars in the upper left of the screen)
Click on settings (the cog)
Select Linked services
If Lutron Caseta is listed, delete it by swiping left or open it and click on it and select the 3 dots in upper right of the window and choose delete
Then go back and try to add lutron caseta back

1 Like

Same problem. I deleted the linked service and tried adding again and got the same issue.

Just curious… have you been able to add any other Smartapps or linked services?

Which leads me to… do you have any adware blocking on your home network such as adguard or a pihole on your network?

Was able to get ST integrated with Alexa and TPLink smart outlet

Two things to try… sign out of the app and sign back in and try installing lutron again.

If that fails, uninstall the app and reinstall and try to add lutron.

If that fails, Contact ST support and open a ticket.

Or hopefully someone else may have thoughts on resolving the issue.

Thank you for the help. Tried everything and still the same problem.

Deleted and recreated my samsung account and that fixed the issue.