Connecting to Lutron Smart Bridge Failure

SmartThings v17.14
Lutron Smart Bridge v4.2

I have setup my Lutron Smart Bridge and it successfully controls the attached Caseta devices. My Logitech Harmony remote can connect to the Smart Bridge and control the devices. Google Home can connect to the Smart Bridge and control the devices. When I attempt to add the Smart Bridge (via Switches & Dimmers, Lutron Caseta Switch, Connect Now) it requests my Lutron Login and Password, and then asks to Authorize it, and then displays ‘Your Lutron Account is now connected to SmartThings!’. I click Done and it performs a Device Discovery … which repeatedly fails.

The Smart Things log is below.

Please note, Google Home and Logitech Harmony all talk successfully to the Lutron Smart Bridge. Why is SmartThings having a problem???

62382e75-1ff2-4206-bb78-f8b5f4587009 7:49:45 PM: debug Page 2
62382e75-1ff2-4206-bb78-f8b5f4587009 7:49:45 PM: debug deviceDiscoveryPage()
62382e75-1ff2-4206-bb78-f8b5f4587009 7:49:41 PM: error response has error: 404
Failed with status code 404
No bridge found on Lutron account.
62382e75-1ff2-4206-bb78-f8b5f4587009 7:49:41 PM: debug getChildDevices(false), children=0
62382e75-1ff2-4206-bb78-f8b5f4587009 7:49:41 PM: warn No bridge found on Lutron account., devices might be offline (errorCode=404)
62382e75-1ff2-4206-bb78-f8b5f4587009 7:49:41 PM: debug discoveryHandler()
62382e75-1ff2-4206-bb78-f8b5f4587009 7:49:40 PM: debug Page 4
62382e75-1ff2-4206-bb78-f8b5f4587009 7:49:40 PM: debug Send bridge discovery request
62382e75-1ff2-4206-bb78-f8b5f4587009 7:49:40 PM: debug startDeviceDiscovery()
62382e75-1ff2-4206-bb78-f8b5f4587009 7:49:40 PM: debug deviceDiscoveryPage()
62382e75-1ff2-4206-bb78-f8b5f4587009 7:49:29 PM: debug getChildDevices(false), children=0
62382e75-1ff2-4206-bb78-f8b5f4587009 7:49:29 PM: debug Clear state
62382e75-1ff2-4206-bb78-f8b5f4587009 7:49:29 PM: debug oauthCallback()
62382e75-1ff2-4206-bb78-f8b5f4587009 7:49:06 PM: debug oauthInitUrl()
62382e75-1ff2-4206-bb78-f8b5f4587009 7:48:58 PM: debug Page 1
62382e75-1ff2-4206-bb78-f8b5f4587009 7:48:58 PM: debug deviceDiscoveryPage()
7:46:35 PM: info Waiting on events…

Apparently this is a known issue …

Hello Dan

Thank you for contacting SmartThings Customer Support. I’m sorry to hear you’re having trouble with your Lutron device discovery, but I’ll be happy to assist!

There is currently a known issue with the Lutron not discovering devices and we are looking into this. We apologize for this inconvenience and we appreciate your patience while we work to correct this. One way I’ve seen users work through this is to hit Done and then search for the devices again. After a few tries, the devices will show up. This is not a guaranteed fix, but it could work for you. We will keep this correspondence open so we can reach back out to you once this issue is resolved.

Please let us know if you have any further questions or concerns. Thank you!

Hope you have a great day!

Vincent Ruiz - SmartThings Customer Support

Was there any resolution to this issue? I’m having the same problem now. All the lutron switches were working fine until recently. Then all of my Lutron dimmers stopped responding. They were showing offline in ST. Removed all the switches, tried to rediscover, getting “Discovery Failed”.

I had hoped the latest update to the SmartThings software would have fixed the problem … but, no, it is still broken.

Has there been a solution to this problem? I added my lutron bridge which connect all my dimmers yesterday. Everything worked fine in both smartthings and lutron apps. Today, when my dimmers did not respond is when I saw the message that no bridge was found on lutron account. My lutron app works fine.

Not that I am aware of. Just tried again and the SmartThings app still reports ‘No bridge found on Lutron account’

I would love to hear from anyone that has this working…

Well … it is now working! I removed the account associated with the Lutron Bridge using the Lutron app. I then created a new account, associated it with my Lutron Bridge and now SmartThings finds it…

Of course, your mileage may vary

I’m having this issue here in Feb of '18. Any ideas where I can begin troubleshooting?

I am having a similar problem in Feb ‘18 also. I have 2 Lutron Caseta in-wall dimmers and 2 Lutron Caseta plug-in dimmers that have been working fine in both the Lutron app and the SmartThings app for months. A week ago I added a third Lutron in-wall dimmer. It is working fine in the Lutron app, but I can’t get it to appear in the SmartThings app. Every time I go to add a Lutron dimmer, I get a message reporting my existing 4 Lutron devices, and reporting there is nothing to add. I know Daniel solved a similar problem by deleting his Lutron account and starting over, but I prefer not to do that unless it is the only way to add a Lutron device after the initial sync.

Something is a bit funky on the Lutron side me thinks. I was able to resolve this simply by resetting by hub. It now shows up as hub 2 since for some reason my account thinks hub 1 is somewhere in the ether however SmartThings picked it right up after doing that.

I just set up my Lutron Bridge and added all of my devices to it and I am getting the same error. Has there been any resolution to it?

Having a similar experience, can’t add new Lutron caseta devices to my smartthings hub.

It was a pain, but I had to remove all my switches, delete the smartapp, add the smartapp and rediscover. I pretty much had to do everything all over that had anything to do with Caseta (Alexa, Routines, ActionTiles, etc).

I’m having the same problem, but I can’t uninstall the Lutron Connect SmartApp. I’ve tried from both my phone and from a desktop and the online dashboard. Every time I try to uninstall it, I get an error that says, “There was an error uninstalling your SmartApp”. Has anyone experienced this? Anyone have a solution?

I have experienced this when the devices are still in use, Example for me MS Cortana was still connected. Once I removed all previous connections, I was able to remove the app. You might try looking through the Dev Dashboard as well for more visibility.