Smartthings linking old data when linking with Kasa

Hi there,
Been using Smartthings linked to TP-Link Kasa for 2 years with no issues until a couple of days ago.
Today I discovered that the link with Kasa integration is broken. I tried all sorts of solutions reconfiguring the Kasa app, re-linking ST and Kasa, Deleting and reloading the apps but the problem persists.
I have no HUB and working solely with the IOS apps from ST & Kasa.
I was able to easily restore all the devices in the Kasa app but for some reason I cannot have ST to retrieve the most updated names and settings from Kasa when linked.
I deleted the ST app and data but still no success. Even the ST web app (not the IOS app) on my Mac is not showing the most updated info displayed on the Kasa app. I am stuck now with all my scenes and routines not working on ST app…

Any suggestions??

1 Like

When you say “re-linking” ST and Kasa… does that imply you removed the kasa linked service in Menu > Settings > Linked services and added kasa back? That would be the option I would suggest if you haven’t already. Removing/reinstalling apps will not resolve the issue.

Yes, I tried everything with no luck.

I removed the linked KASA service in Smartthings, then deleted the app and re-installed.
Also, changed the pwd on both apps (Smartthings and Kasa) and reloaded both.
For some reason, the KASA is working perfect and displaying all changes (device names and such) but when I request Smartthings to re-link with Kasa, an old version of my changes appear.

I don’t know what else can I try…it seems that the version is stuck in some sort of cache in Smartthings and never updates

One warning… changing your Kasa password is a sync killer and the only solution is to remove the linked service in ST and add it back.

Best advice is to contact ST support and see what they say.

I will contact ST tomorrow, I already lost all my scenes and automations… :unamused:

One more question…Will adding a HUB make stuff more manageable?

Hub would not have any effect since kasa is a cloud to cloud service.

There is an Edge Driver for some Kasa devices which requires you to have a ST hub.