Kasa TP-Link plugs with SmartThings using Linked Services - no longer working after password change

I have been using some Kasa TP-Link plugs with SmartThings using 'Linked Services. All ‘was’ well. I then had to change my Kasa TP-Link password. Now the plugs no longer work with SmartThings and I am unable to delete the Linked Services with Kasa so that I can link again using my new password. Please help with this ASAP. I have been trying to think of ways that I can rectify this but have come up with none.

Many thanks.

Paul Bromley


What happens when you try to delete in menu > settings > linked services? Any errors?

If I click on TP-Link/Kasa I am not taken to the delete menu option for it. I very briefly get a whirling disc and then it returns me to my list of Linked Services - presumably because I do not have a valid account linked to them due to the password change. Very frustrating. Had I known this would happen I would have deleted the link before changing the password. I assumed (wrongly now) that SmartThings would allow me to update my password.

Left swipe on the integration

Great - many thanks! Drat - why didn’t I think of that! All sorted now and working - many thanks as had quite a few things linked to the plugs.

I’m having the same issue after changing my kasa account password. What does “jkp” mean by swipe left on the integration? I’m using the latest version of the ST app and nothing happens if I swipe on Kasa from menu>settings>linked accounts > kasa.

All devices can be switched on/off after changing the password from the kasa app, but show offline in ST. Surely it’s not necessary to remove kasa integration from ST and start over, this would delete all 20 devices and associated integrations?

As a test I deleted one device then attempted to add it back but it does not appear in the kasa device list and clicking DONE does not generate an error. I also tried changing the linked eWelink password and that did not break anything, does this mean all integrations are not equal.

I don’t look forward to recreating all kasa automations so any suggestions are welcome.

That part is correct. Each linked integration is maintained and managed by the company of that device.

Contact ST support to get their recommendation on possible solutions. The only option I can offer is to remove the integration and add it back.

I know you tried removing/adding back a Kasa device and that failed. Try opening the integration in Menu > settings > linked services and click Done. See if that gets the device back into ST. Doubtful but worth a try.

Tried before posting, no luck! Waiting on ST support for suggestions.
It seems crazy that a rebuild is the only way out. Recreating the devices isn’t too bad but all those automations is a real pain.

Finally got everything recreated but one Kasa device (smart plug) is duplicated in IDE but not in the ST app, both have the same network ID. I removed it from Kasa which eventually updated ST but the “ghost” device from the original install still shows in IDE and replicates to other services linked to ST.
I have tried deleting from IDE, even though deletion is confirmed the rogue devices is still there after the device list refreshes.
Any thoughts on how to clean this up?

Figured it out. Changed the network ID so something unique then I was able to delete it.

Network ID? You mean the Device Network ID in the API?