Smartthings Link For Nvidia Shield Z-Wave Discovery broken

I have been using a Smartthings Link on my Nvidia Shield since it was released about a year or so ago without any issues. I have several Z-wave devices paired and in-use running without issue.

Recently, (and I cannot pinpoint when it started but it has been at least a month) I am no long able to discover any new z-wave devices with smartthings. At first I just chalked it up to a bad switch that I got deeply discounted and installed well past the return period and thought nothing of it, but I got several new z-wave devices (including a Schlage connect lock which is directly supported in smartthings) for christmas and I have not been able to get ANY of them to be discovered into Smartthings.

All of the devices will respond to exclusions, but will never be discovered during the pairing procedure.

To add to this, the other night, one of my z-wave switches that had been working without issue dropped off my network and even out of the app all-together and it no longer is discoverable either. I had noticed that this light was always reporting as “on” regardless of state for several weeks. It still toggled on/off and brightness but would never update in the app or actiontiles.

My remaining z-wave switches still function within the app as expected but the situation seems to be degrading.

I was able to pair Samsung Branded button and multipurpose sensor through zigbee about 2 weeks ago and they seem to function mostly as desired. (The button doesn’t always respond on first touch but one issue at a time)

Has anyone experienced this or can anyone offer any solution that I might try to get z-way up and running again?
Someone on the Facebook group said that this is an issue with the Link but the ST Link literally has one job and that is to act as a zigbee and z-wave antenna.

I have tried rebooting the hub, shield, power cycling the devices, physically touching the hub to the device, countless exclusions. I reached out to samsung support about a week ago and have yet to hear back other than their generic “we’ll get back to you when we can… warm regards” message.

Any troubleshooting or advice is greatly appreciated.
Thanks in advance!

Mine dropped the 2 light switches for my ceiling fans. All the bulbs going through my Phillips bridge are fine. Just the 2 Leviton switches won’t respond and won’t reconnect. Started about the same time yours did. I want to say it was around the time I upgraded to Shield 7.2.

Now when I unplug my Smartthings link and plug it back in it no longer automatically opens the Smartthings app. Something got broken by nvidia I think. Maybe try opening a case with them as well.

I found in another forum somewhere (I think it was on here) that it was actually a Shield firmware update that broke smartthings. There have been a couple updates since that have not fixed it. I sent feedback through the shield to Nvidia but have not heard anything (don’t really expect to). I opened a ticket with smartthings and (now 20 days later) they finally got back with me offering some basic troubleshooting suggestions that I’ve already done (power cycling, network repair, etc.) But of course I don’t have the time now to mess with it for a few weeks. I’m not hopeful, however. I believe it’s a nvidia issue.

I bought a v2 hub that was delivered this week. I may just bail on the link all together. It’s a shame, the link worked really really well, until it didn’t.