Smartthings hub V2 recently purchased

I recently purchased V2 after power it on for several mins, v2 reaches to solid green led but after certain time it toggle between green and blue led. I also tried to register it via code that comes in the box but it say " network problem or server is down"

I search for green and blue led flashing on web did not find related info nor in the ST documentation led status green and blue led flashing meaning stated.

could be due to device faulty ?

tagging @SamsungZell

Hey there! @Omair_Misbah, Thank you for reaching out for assistance with your v2 Hub.

I would first attempt force closing your app and attempting to add your specific hub by model code: STH-ETH-2

A solid blue LED means the Hub is attempting to connect to the SmartThings cloud/servers. if the light remains solid blue for longer than 5 minutes, this indicates the Hub is unable to establish a connection with our servers.

Unplug the power cable and remove the Hub’s batteries for 30 seconds, then plug the cable back in and replace the batteries. Wait until the Hub LED is solid green and try connecting again. Attempt to reboot your router to see if the symptoms persist.

You can then attempt a factory reset of the device using the steps below:

Disconnect the power cable and remove batteries from the Hub
Using a pin or similar tool, hold the reset button on the back of the Hub
While continuing to hold the reset button, replace the power cable
Continue holding the button for more than 30 seconds
When the LED switches from flashing yellow to solid yellow, release the reset button
Reinstall batteries into the Hub
Note: If you do not release the button within a few seconds after the LED switches to solid yellow, the Hub may not begin the reset.

If the symptom persists, I would recommend creating a Support ticket so we can look into your concerns further.

You can reach out directly to a support team in your area using the below information:
US: 1-866-813-2404

I hope this message finds you well!



I did all these troubleshooting but hub remain on green soild for few seconds and then turn to blue solid this thing happen in loop.

During this I went in to smartthing application and try to add the hub by clicking hub and then Samsung then select ETH hub option which is my type of hub

After putting the code it give error network or server problem.


Thank you for attempting those steps.

Are you using an Andriod or IOS Device?

Do you notice any changes in the symptoms if you Clear the Cache on Android or Clear History and Data on IOS?

Additionally, Double-check the router’s network settings:

  1. Confirm the following ports are open:
  2. 9443 (V2 STH-ETH-2 only)
  3. 443 (normal operation)
  4. 39500 (internal server port that must be open to use LAN connected devices)


I am using android phone and I tried to register using two different internet but result same.

Is it possible that ST Hub can only be use in US or UK. I am in Pakistan and trying to register it from here.

For your instance, I would recommend reaching out to support in your area. Unfortunately, I’m only able to advise of US models due to differences in the International firmware of devices.

Here is the contact information for PK.

0800 726786
0900-0000 / 7 Days a Week

I hope this helps you further.