SmartThings Hub v2 (2015) and ST connect

Hello all. New to this community but a longtime user of ST. I recently bought a Sensi thermostat and wired it to boiler. On the box it said ST compatible, later to find out only with Connect, not classic. So I d/l connect and can’t seem to get my SmartThings Hub v2 (2015) to be found/seen by ST connect. I have tried searching for an answer but cannot seem to as to weather or not SmartThings Hub v2 (2015) is compatible with Connect. Thanks in advanced for any and all help regarding my post

Yes it is.

I believe those thermostats are WiFi, right? In the new app (assuming that’s what you mean) when you go to add a new device, select “By Brand” and scroll down to Sensi and walk through the discovery process. Is that what you did? If that didn’t work, then there’s probably a cloud to cloud integration issue that either Sensi or ST support will have to help resolve.

BTW - the process will take you to a Sensi logon prompt, so make sure your thermo is set up properly on Seni first.

You need to check that you do not have two Locations. You can check in IDE at or click on the menu (three bars in the upper left of the screen) in the new app and location should be listed near the top with a down arrow. Click on that down arrow and ensure you do not have two locations. If you do, click on the other location to select it and see if your hub and devices appear. If you do have two locations, we can show you how to remove the empty one. Just let us know if you do.

Ok, first thank you for your help. I do infact have 2 locations (one for my wife, not sure why) but it’s empty. the first is mine which has all my devices in it. I tried to delete it the obvious way but got an error:
500: Internal Server Error
Reference Id
Fri Jan 24 12:53:17 UTC 2020

You should be able to delete it from the new app in the same place I pointed you earlier.

Also, following #2 in the following thread… using IDE in incognito/private mode in your browser.

1 Like