SmartThings Community

Re-connecting SmartCam HD to SmartThings Hub v2

cameras

#1

Does anyone have any experience “re-connecting” SmartCam HD to SmartThings Hub? In other words, if you have added the camera and removed it, were you able to connect it back?

I integrated Samsung SmartCam HD to my SmartThings Hub v2. It worked fine and I could view the camera from SmartThings App itself, without using SmartCam app. There was this known problem that the sensor from camera could not be utilized from SmartThings. This post is not about that. I have a SmartThings motion sensor to do the job, and it works fine for me. The camera stream was clearly accessible from SmartThings app on my phone, and that was good enough for me.

The SmartThings Hub and the camera were on the same network:

  • SmartThings hub was connected the wifi hub using a network cable
  • SmartCam camera was connected to the same hub over wifi
  • Let me call this network/hub, Foo.

I had some problems with my wifi network Foo. I had another network Bar that had better reception where the camera is located. So I did this:

  1. I used SmartCam app to move the camera to the other wifi Bar
  2. I moved my SmartThings Hub to the network hub for Bar using a network cable
  3. I verified that all the sensors were correctly reporting status to the hub (since the physical move wasn’t much, I didn’t have a problem with sensors reporting status)
  4. But the camera stream was no longer available from SmartThings app. The stream was/is available if I use the SmartCam app which I installed to test this. But not from SmartThings app
  5. I removed the connection from SmartThings to SmartCam using “Remove device” in the app
  6. I tried to connect the camera again, but looking for “Existing cameras”, but the camera is just not discoverable
  7. I perform a factory reset of the SmartCam, re-configured it, tried to re-connect it with SmartThings. But the camera is just not discoverable
  8. It might be worth mentioning that I performed this re-adjustment on 11/10 and I SmartCam app prompted me for a firmware upgrade. So I went ahead with a firmware upgrade.

The camera is clearly connected to the network because I could access the stream when I installed the SmartCam app on my iPad to access the camera. I don’t want to install the app on multiple phones that we use to access SmartThings. I only want to use SmartThings app to access the camera. Plus there could be app improvements coming in SmartThings with better integration to the camera (perhaps sensor data), I don’t want to loose out on that. So, I do want SmartThings to be integrated with this camera.

Any suggestions or ideas on how to get my SmartThings hub to re-connect to my SmartCam?


#2

After trying re-connection for a day, I stopped retrying for a day. When I tried again today, the camera was discovered. I don’t know what changed. I did not reboot the hub or the camera. And I had definitely waited for much longer in the past. So, for now, the problem seems to have been solved for me.

Thanks.


#3

Same thing happened to me with regards to removing and only being able to readd the following day. Watching to logs, it seems all of my cameras were found, just not able to connect. However, my video still isn’t streaming. I detailed my post here… Samsung (un)Smart Cam and Smart Things


#4

Thanks for your note @maXiom. My hypothesis was that there is some sort of cache of device ID (camera device ID) that had a expiration of 1-2 days. But your problem disproves my hypothesis. I hope you find a solution.


#5

Thanks. Just tried to add the cam back again. The video stream still isn’t working for me. Maybe I’ll reach out to SmartThings again…


#6

Hi, I’m having the same problems with a Smartcam Plus 6417.
Any tips you can share with me?

Thanks


(Paul McGowan) #7

Anyone who can help - I have the Samsung SHN-P6410BN cameras and Smarthings no longer supports them in the marketplace. I see that I can add a device on the IDE called Samsung Smartcam but how do I then active it and connect it to my actual camera?