Smartthings Home Monitor shows no devices even though they are there

Since the migration, I have no devices show up under STHM even if I try to add them. I have smoke detectors etc. selected.

Uninstall STHM, then reinstall it from the SmartApps section. Usually does the trick.

Tried that, still doesnt show the devices under the monitor. It does “look” like its setup but hard to say.

Does your hub show in the device list?

Yup. I have most things working just STHM has not worked right since migration.

Just checking…

You are going to menu > SmartApps > click on the 3 dots in tHe upper right of the screen and select delete then choose SmartThings Home Monitor from the list?

Yes, and making sure its gone in the IDE. Then reinstall it. It seems setup right just that no device shows.

You should contact ST support and let them investigate.

Also, STHM does not show in IDE :slight_smile:

1 Like

@Adam_Smith ,did you ever resolve this? It’s happening to me now.

Figured it out. If you don’t select all sensors in all three STHM components you’re screwed. Just another bug still not fixed in this getting worse new app…