"SmartThings has stopped" When Using Z-Wave Utilities

(I Googled those words … no joy.)

Using a re-booted fully-updated Samsung Galaxy s7 + newer SmartThings app (Version + brand new Aeotec SmartThings Hub model AEOHUBV3-US (is using my home’s wireless WiFi):

When I use Z-Wave Utilities, an error box opens saying “SmartThings has stopped. Open app again.” Would someone please tell me how to fix? (Goal: to disconnect my devices in the app, so that I can add them in the app to connect them to my new hub.)

you may want to try clearing the data cache for the app and see what happens. if that fails, uninstall the app, reboot your mobile device, reinstall the app when it boots up.

Thanks jkp. I tried everything you said. I even uninstalled a bunch of other apps that I no longer needed, to create more space on my cell phone. I even did a factory reset on my new Aeotech hub. Nothing has worked.

Every time I choose Z Wave Utilities, my phone says either “SmartThings has stopped …Open app again” or “SmartThings keeps stopping …close app”.

Short of buying a new cell phone (which I can’t afford), I don’t know what else to do. I welcome any additional ideas, from you and from anyone out there.

you can use z-wave utilities in IDE at https://account.smartthings.com

when you login, go to hubs > find view utilities on tHat screen.

also, report the issue to ST support using the app > menu > help and include the logs.

1 Like

Thank you. I logged into my IDE and clicked on Z-Wave Exclude. This sentence popped down, “Z-Wave exclude mode initiated for 15 seconds.” I pressed the button on the motion sensor to help it get found and excluded. Tried this several times. Nothing ever happened.

So I called Samsung Smartthings tech support. They checked my system and said that the Monoprice motion sensor had not been excluded. They said it’s because the Smartthings app no longer supports the Monoprice brand, and neither does their hub.

I asked… what if I try and use the Smartthings Classic app that’s still on my phone? They replied that it will crash because they no longer support that app.

They said that because Smartthings no longer supports the Monoprice brand, the new v3 hub I bought, and my Smartthings app, will not be able to work with anything in my house that is Monoprice.

That is unfortunate, because 3 years ago, I spend $3,000 buying security for my home and 95% of it is Monoprice. Do you happen to know if there is a hub system “out there” that does work with Monoprice sensors?

I have 2 monoprice Z-Wave outlets and 1 monoprice Z-Wave motion sensor on my system and they are all working just fine.
I have a v2 hub and use the v3 app.

1 Like

{thunk, thunk, thunk} (that’s the sound of my head banging against the wall) :confounded:

The SmartThings V3 hub is a certified zwave controller.

The monoprice zwave sensors are certified Z wave end devices.

Therefore SmartThings must work with those devices (of any brand) at the “basic“ level. Basic has a specific meaning in this context. Basically it’s on/off/dim for switches and recognize an event report for sensors.

It doesn’t mean it will understand battery level reports, and it might not get a “motion inactive“ report. But if it says it’s a certified Z wave hub, and the smartthings hub does, then it Has to work with zwave devices regardless of brand at this basic level. So not only was support incorrect, if the statement they gave you was correct it would be at the very least an FTC violation.

@Brad_ST @tpmanley

Now if it was one of monoprice’s Wi-Fi devices, that would be a different story, because so far there is no standard third-party certification for those.

And if you just add the monoprice device using the generic Z wave motion sensor, it’s possible that you won’t have all the features you might’ve had from a previous custom DTH.

But yes of course the V3 hub should work with a certified Z wave sensor. That’s the whole point of zwave! :rage:

And as far as an exclusion, as long as you are using a general exclusion, that should be accepted by any certified Z wave device as long as you do the correct steps with the device itself to accept the general exclusion.

This is just zwave 101 stuff, nothing specific to smartthings.


  1. follow the instructions for a Z wave general exclude:
  1. find the manual online for the specific model of sensor that you have and follow its instructions for accepting the general exclude.

  2. whether you get any message from smartthings or not, that should succeed in clearing out the old network information in your sensor. Now it is ready to add

  3. if just adding it through the app doesn’t work, then you will have to search the forum and see what DTH people are using with the specific model of sensor that you have.

Always list the model number, it does make a difference.

I’m sorry you were given such incorrect information, but as long as the device is a certified Z wave device, it doesn’t matter what the brand is. You should be able to get basic functionality with a smartthings hub, with the caveat that “basic“ has a very specific meaning in this context. It may not be the functionality you were looking for and it may not be the same as the functionality you had in the classic app, but you should definitely be able to add it to the network and do something with it.


Two more points about this brand…

Most of their motion sensors have an obvious looking “tamper“ button. That’s not the one you want to press during inclusion/exclusion.

Instead, there’s a pinhole that you have to insert a pin or toothpick into and press down. So there’s that.

Second, if you have paid the license fee for the third-party Rboy apps code library, they have a DTH for the monoprice sensors which does seem to be working with the new app. Rboy has a lot of different code, both device handlers and smart apps, and there’s a single one time fee that gives you access to everything.

Normally people only need to do that if there are some advanced features that they want access to, it’s pretty sophisticated code. But since you said you had a significant investment in your existing devices, it might be worth it to you to get them working.

Here’s a discussion thread about it. He doesn’t say there that it’s paid code, but it is. The library is very popular with people looking for those kinds of advanced features. @rboy also gives a lot of free advice in this forum. so you might at least ask him if the monoprice Devices that you have (again, he will need the model numbers) Will work with the current app and the V3 hub with his code or not. See the following thread:

[RELEASE] Official Monoprice Motion Sensor with Temperature, Tamper and Battery Device Handler

1 Like

Dear JDRoberts, I was SO relieved to read your messages this morning, and thank you SO MUCH for all of your helpful advice! I will indeed try your suggestions, starting with the basics. All I need from my Monoprice devices are the basics … a door was opened … or someone entered a room.

I have obligations this morning that prevent me from trying your suggestions, but perhaps I’ll be able to try them this afternoon or tomorrow. Then I’ll post here how things went.

I do know the first name of the tech support person who gave me that wrong info, but I don’t want to get her in trouble or cause her to loose her job. I think she just needs to get better training & become better informed. I think what I’ll do instead, is reply to her email (after I have worked out the issues with my new hub) to let her know that my new hub does indeed work with Monoprice-brand-devices. I’ll email her a screen capture of a Monoprice device working, as proof.

Thanks also to Paul for his input.

1 Like