Smartthings doesn't show jetbot+ map, schedule, no go zone etc

I bought jetbot+ and after I followed the instructiong of connectiong it to wifi, smartthings and registering it I am redirected to a blank screen where I cannot control the jetbot, I cannot see the map etc. I cleared the cache of the smartthings app I deleted the jetbot, cleared the data, reinstalled the app, rebooted my phone (samsung galaxy s10) but nothing helped. I tried to add the jetbot to another account on my tab s7 but same issue. I also tried with a third device(Xiaomi) but same issue. When I press and hold the “play” button on the jetbot it says it’s connected to the wifi and the signal is strong. I believe there some issue with the app or registrating the product. I was also disconnecting the jetbot couple times by holding the “go home” button and reconnecting it again but that didn’t work as well.

Does anyone had this problem and what are the potential fixes?

Same here! Since two weeks I can’t access and control the jet bot+, it’s just black blank screen. Tried clearing app cache, uninstall and install, add the device again to no avail. Using Galaxy S21 with the lastest software updates.

1 Like

I recently purchased a Galaxy S24, however, the problem persists, leading me to believe that the issue is not device-specific. :man_shrugging:

I’m wondering if we will get a response, because I’m thinking of switching to other devise. Да им се, не знае.