SmartThings could not validate the webhook URL for Home Assistant

I’m using Home assistant OS version core-2021.12.4
I have acces from outside with duckdns using NGINX
Trying to integrate Smartthings
Searched all over for an answer
Very frustrated :disappointed:

Message says: “SmartThings could not validate the webhook URL. Please ensure the webhook URL is reachable from the internet and try again.”

Home assistant logs says:

Logger: homeassistant.components.smartthings.config_flow
Source: components/smartthings/smartapp.py:145
Integration: SmartThings (documentation, issues)
First occurred: 10:37:25 AM (2 occurrences)
Last logged: 10:50:43 AM

API error setting up the SmartApp: {‘requestId’: ‘A5817636-5B00-4FF5-BDC4-5667F0FA73E7’, ‘error’: {‘code’: ‘ConstraintViolationError’, ‘message’: ‘The request is malformed.’, ‘details’: [{‘code’: ‘TargetTimeoutError’, …

Any ideas?

Its either:

  1. SmartThings cannot reach your external url. (admittedly if you’re using the HA companion app successfully this likely isnt it, same configuration location)
  2. could be the ssl cert for your external URL. If the cert authentication cannot be verified, connecting will fail.
  3. Is smartthings down? No seriously, not being trite. The first time I tried to set mine up I didn’t realize ST was having an outage and I spent three hours troubleshooting a HA issue before I went to the SmartThings Status page and saw an outage listing.
3 Likes

I would add @nathancu’s comment, that in most of the case when you try to set up something like this, make sure to access your HA through your outside address and not your internal one.

1 Like

Just made a quick check (with dns checker) and my ssl is valid.
Just in case I rebooted Smartthings, even though it was working fine.
Im sure I have external access to H.A. since I can connect from a different network outside my house. I can even shut down my phone`s wifi and can still connect using my phone´s internet.
I just installed Alexa´s skill with H.A. which needs to access HA on SSL from outside also, and it works perfect.
Its just Smartthings integraton my problem.

Have you tried going through the removal instructions (specifically the part about the utility to remove orphaned smartapps) and then starting with a fresh configuration?

Its the only thing I havent tried, and maybe its because I dont have a clue how to run it. I know its linux but I tried running it on the HA terminal but says

bash: pip: command not found

. Should I run it directly from the pi on which HA is installed?

Would someone please help me on how to run this?

The Home Assistant forums might be more helpful in this instance.

I’ve not actually run the removal tool before, I’m only aware of it’s existence and have seen a few others post that it fixed their issues.

1 Like

Yes I would post this in the HA forum.

That said yes you need to SSH into the host and run the command from there. The error you are getting is telling you wherever you are running now does not have an appropriate version of PIP package manager installed. That is usually dependent on Python. (i had a similar issue and had to manually install both Python 3.9 and then install a version of PIP that works with Python 3.x) before the tool would run.

Post this over there and im sure someone will pick it up and help walk you through.

1 Like

Thank you. Just did. Crossed my fingers…

2 Likes

How did that work out? Were you ever able to integrate the SmartThings hub into Home Assistant?