Smartthings integration in Home assistant fails. Can not authorize the smartapp

Hello everyone, I would like to ask for your assistance. I have a smartthing hub and various devices connected to the hub. Alsi ii have a Home assistant io platform running. In the past I was able to integrate smartthing to hassio and now I run into problems.
I have followed all paths to solve the problem , but i was unsuccessful :frowning:
I have home assistant configured with ssl certificat for external connection. I use duckdns.org and letsencrypt. I have checked the connection from exernal and I’m able to connect to the server. I’ve also checked the certificats and everything is fine.
I follow the integration steps from home assistant, everything goes ok until I reach the level in home assistant after I introduce my token and location, and i get a message that i need to make an authorization to an external link. I click and a new pop-up window is opening with the following address :" https://strongman-regional.api.smartthings.com and I get the message error… please install the smartapp again. I made this step several times and the same. I would really appreciate and indications to check if I have a wrong set-up or and indications on how to resolve the problem. Many thanks. Adrian

Someone recently had this issue and I gave them some ideas on the thread below. Do you want to try these things? If nothing works let me know and I’ll try and think of some other ideas.

2 Likes

Hello Tim, i have hassio 5.8 version. I’ve checked this post that you indicate before posting. I do not have the issue with the “theme” to remove.
I do not have nginx. For the ssl i have them localy.
As i have hassio i can not in the terminal install hass_smartthings_remove as i get unknown cmd pip. I tried to make IFTTT webhook post method, and IFTTT accepted the applet, the applet was a simple press button that generate a webhook and this triggers with an automation a switch in hassio. Unfortunate this is not working, I try to check why.

I succeded to make the webhook to IFTTT work, I had an error in my automation, so the home assistant webhook to IFTTT works fine, I tested. Let me know if you have any other ideas on how to determin which problem could be with the integration of smartthings! Many thanks in advanced

So if webhooks are going through for IFTTT it really rules out some sort of firewall or SSL issue.

You likely have some corrupt instance of the smartapp still running in the Smartthings API that is messing things up for you. That is what the cleanup tool mentioned here fixes - Can't Remove Home Assistant smartapp .

The cleanup tool is a python file that runs a script that cleans up the Smartthings API side, so you don’t actually install that file in Hassio. You need to run the python file from another machine that has python installed. I really think you need to run that cleanup file to fix your issue. You download the file to a directory, and then from the directory the file is in, run the command - pip install hass_smartthings_remove . Then you run the command hass_smartthings_remove PERSONAL_ACCESS_TOKEN and replace PERSONAL_ACCESS_TOKEN with your smartthings token. If you lost your old one you can get a new one here - https://account.smartthings.com/tokens . When you make that token, make sure everything is checked to allow the token to access all parts of your Smartthings account.

If you aren’t familiar with python scripts or are running into errors this link should help provide more information on how to do it - https://packaging.python.org/tutorials/installing-packages/ . There’s python 2 and python 3 - python 3 is the newest but I think you might need python 2 to run this script.

1 Like

Hello Tim,
Thanks for the indications, I did the instalation of hass_smartthings_remove, with pip install did not worked because aiohttp needs python 3.4 or above, so then i’ve installed with pip3 install. Then i did not remember the old personal token, so i generated a new one with all topics clicked, run the hass_smartthings_remove with the new token, and 2 instancies were found, and removed. I was happy as I told myself, great now it will work, but then I went and created a new token only with the clicks defined in the hass integration, and I run in the same problem, after i indicate the location for the integration, in hass i ger a message that i need to open an ourside web adress for authorisation, which takes me to https://stringman… and get the same error, that something went wrong, and to reinstall the smartapp :(. Any other idea would be great. Many thanks in advance

Hello Tim, then I tried again to add, did not run, then got some errors, then used the hass_smartthings_remove with a token only with the 6 checks, then I did a restart of hassio, then tried again and worked. Many many thanks. :blush:

1 Like

Awesome news. I know if was a pain but will be well worth it. I really like running home assistant and Smartthings together.

1 Like

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.