SmartThings connection doesn’t connect!

SmartThings connection never connects! I have two houses and everything had been up until recently the app doesn’t connect to the hubs! I have ring cameras and both of those sync up in a split second. Minutes go by and my phone eventually goes to sleep!!

What on earth is going on??!!

I read remove from favorites, but I can’t because it doesn’t connect. I’ve rebooted the hub, no difference.

Someone said log out, but when I go to that page on the app it says it will delete the app and all info!!

Can someone at Samsung please explain what is going on??!!

Former happy customer
Mr Bill

You lost me! :slight_smile:

What is SmartThings connection that you are referring to? Once I figure that out, perhaps I or others, can offer more assistance because I am not certain what you are trying to remove from favorites, etc

more details would help…
which hub or hubs do you have?
android or iOS?

iOS app

When I select any device I get a connection screen below but it never connects

I have two houses, two completely different setups and neither one is connecting.

Phone goes to sleep 3 minutes later still no connection.

Both of these systems have been in use for several years. And I haven’t had any trouble with them up until recently. So something has changed! And no one seems to know what it is.

I can control the thermostat through Alexa which I believe is still talking through the smart things hub but not through smart things app.

I can access ring devices and using the Honeywell app control one of the thermostats. I know the internet and router are fine.

The only thing that isn’t working is your system!!


TV - IT Engineer
US Senate TV 13 years
It technician 30+ years

I have the same issue! I removed the app, and reinstalled and it helped for about a day. Now I am back in the same sport…can’t see my network connection for some reason

1 Like

ok… let’s try signing out and signing back in… yes, I know you got the delete the app and all data which means you were in the wrong spot.

go to Menu > click on Settings (the cog in the upper right of the screen), click on SAMSUNG ACCOUNT with your email listed below it > select Sign out

In order to get the Delete all data… you were in Menu > Settings > Leave SmartThings (WHICH ANYONE WILL WANT TO AVOID AS IT PERMANENTLY DELETES YOUR ACCOUNT AND ALL DATA)

I just updated my smartthings app (IOS) and it resolved the issue. Hopefully it will stay connected

glad you got it working

It’s still not working!! You confusing me with someone else?

try uninstalling/reinstalling the app

I was about to do that, and an update message popped up, so I updated the app and it now connects after a few seconds. Both houses are now connecting…
So, I’ll let you know if it starts hanging up again.

It’s odd that when I went to the App store, there was no update listed for it. Is that something you pushed to my account?? I just checked the app store again and there was no update listed as available.

not me… I do not work for ST.

The app update was released earlier today. possible it just now got pushed to your device

Pulled down the screen to refresh the page.

The iOS app is a seaming pile of sh!t. Many of us have gotten this message perpetually for months. No fix, no acknowledgement from support after multiple cases. Sorry to hear you’re affected.

1 Like

updating the app, logging out and logging back in brought it back to life, so we’ll see how long it takes for it to throw up again. It had been running pretty well until recently.

That didn’t do anything. Once it gets into the connection screen everything locks up.

The app update seemed to help

When I talked about pulling the screen, it was in the AppStore to make the update appearing.

I have updated mine this morning. If I can make it to 3 days without the connection problem coming back, I can say that it is fixed because for the past few weeks, it has been reappearing every 2 days.

Ahh… yeah that makes more sense. Hope your issue is fixed. Mine seems to be…
Best wishes