Smartthings compatability with Samsung Galaxy A7 Lite (SM-T220)

Have 2 old tablets, one running Android 5, the other Android 6. As such, I can not run the latest version of SmartThings on them as well as some other apps.

So… I go out and buy a Samsung Galaxy A7 Lite tablet (4GB memory, 64GB storage) thinking that surely it would run SmartThings since the tablet is less than a year old.

When I went into the Google Play Store i see that the tablet is not listed under the supported devices.

Anyone know why this tablet is not supported by the SmartThings app?

Thanks!

tagging @SamsungZell

The same happened to me. I had to download Smartthings directly from the Galaxy Store and it works correctly, although I don’t understand why it is not in the Google Play Store

cljara80,

how did you download it? if i go to the Galaxy Store and click on Install it brings up a dialog and the SM-T220 is grayed out saying it is incompatible.

i’ve downloaded it from an APK site but would much rather get it from Samsung directly.

did you end up having to sideload the APK?

thanks!

It was not necessary to download APK, I installed it directly from Galaxy Store

Hey there! @gwa000, I’m sorry to hear that you’re having issues with downloading the Smart Things Application.

Have you confirmed that your device (SM-T220) is up to date with the latest software version?
Here’s an article on updating your devices:

Have you also checked that you are running the latest version of the Galaxy Store Application on your tablet?

When you select the Galaxy Store app > Menu > About Galaxy Store.

What version is listed and does it state that you are running the latest version under the version information?

If you continue to have issues with downloading from the Galaxy Store after ensuring everything is up to date, you can reach to the Galaxy Store Support team directly.

Mobile Apps and Services: 18666479190
Note: At this time, it is recommended to use the Mobile Apps and Services email contact form located at help.content.samsung.com

I hope this message finds you well!

^SamsungZell

I bought this tablet last year and the SmartThings app was only available from the Samsung Galaxy app store and runs fine. Even got the most recent SmartThings app update too. I’m in the U.S. so if your not then maybe it’s a regional thing?

i was able to install the SmartThings app from the Galaxy Store.

thanks to everyone who replied with their comments and suggestions.

1 Like

my mistake was going to the Galaxy Store via their web site. that is where i saw that the tablet was not compatible.

when i used the Galaxy Store app on the tablet, the SmartThings app installed successfully.

thanks!

1 Like

@gwa000, Thank you for following back up to let us know that you were able to get it installed!

^SamsungZell