Samsung tablet compatibility

I agree. I purchased my tablet new for the purpose of using Smartthings. Can’t believe Samsung doesn’t support on their new products!

The app uses 70MB-80MB on my phone - more than any other app, but a small fraction of their 2GB minimum.

It looks like someone at Samsung didn’t understand the RAM requirement question in the “distribution dashboard” which controls which devices can install an app. They seemingly used an imaginary recommended hardware requirement rather than the amount of RAM required for the app.

I returned the tablet to Costco.

It would seem that a lot of us recently purchased a Samsung Galaxy Tab A 8" to use as a tablet to control Smartthings not knowing the Samsung Smartthings app would not be compatible due to hardware requirements.

I hope this changes soon, otherwise I will be returning the Samsung Tab A 8" before the return window. It’s not financially feasible to wall mount a $200-$500 tablet just to run smartthings…

Return it now. I bought a Leveno tablet. Works great.


What Lenovo Tablet did you buy to make this work?

Leveno Tab M10 plus…has 4meg ram…$279 on Amazon

I’ve tried rooting the tablet and force-installing the app as a system app. The app runs but cannot complete the login or connect to my devices. I get the feeling that the operating system has been stripped of some necessary modules to run the app, to make the tablet run lighter or something like that.

Of all the tablets in the store, I really thought this one was the obvious choice for being the prefect smartthings controller :roll_eyes:

You and I both, buddy.

I have a Samsung 10.1" Tab A (2019) model SM-T510 with 128GB ROM / 3GB RAM (from Costco) and it works fine.
1920x1200 resolution

I’m not saying what I use, I learnt the hard way, I mentioned something in a thread about a certain app running on my tv, next day app gone

So I don’t own tablets, or what they are

How nice for you. Doesn’t change the fact that samsung doesn’t support samsung products on samsung devices that are currently sold!


I’m pretty damn grumpy about this. They discontinued an app that worked perfect on a tablet less than a year old and replaced it with one that doesn’t work at all.

Seriously Samsung, I’ve had over 40 of your products in the last 10 years, you’ve messed up plenty but this time it’s enough to push me to another eco system. Fix your shit.


Needs > 2Gb of RAM to run Smarthings??? I am trying to turn on my Christmas lights not run a oil refinery!!! Says a lot about the programmers at Samsung.

I didn’t read through all the posts but just got it to install from galaxy store … was not available in playstore… Like others I tried side loading and no go… thanks samsung for making us use two different app stores!

I use the SmartThings app to mirror the TV to my Android tablet. On the TV, the aspect ratio is 16:9, but on my Android tablet, the aspect ratio is mirrored in 4:3 format (shown in the attached file). That’s not OK.

Please help, how to make the aspect ratio in SmartThings same as on TV.

Information about the software and hardware I use:

  • Smart TV model: Samsung UE32M5572

  • Tablet model: Samsung Galaxy Tab A (2016), SM-T580

  • Version of Android on tablet: 8.1.0 (Official firmware: T580OXX5CTK1)

Before, everything was fine while I had Android version 7.0 on the tablet, but now in Android version 8.1.0, SmartThings no longer mirrors the aspect ratio same as on the TV.

When a movie from TV to tablet is mirrored in SmartThings, people look elongated on the tablet. That’s not OK.
Wen I had Android 7.0 installed on my tablet, everything worked fine. Now that I have Android 8.1 installed, the aspect ratio in SmartThings is no longer OK.
Please help.

I bought a Galaxy Tab A7 with 3GB of RAM, and the app isn’t compatible. It has nothing to do with RAM I am betting.

@JMB . Same here. And it isn’t a RAM issue - Tech support told me I needed 2GB free! Not simply 2GB (which would imply installed) on the Play Store. I didn’t believe it either, but humoured them and stripped mine back till I had the requisite ‘Free’ RAM. No difference. Also was able to install on another vendors older tablet with 2GB total and only a few hundred MB free.

I know this thread is getting a little long in the tooth, but fwiw an install from Samsung store works fine, so possibly play store issue?

So, just to be clear…I have a beautiful big screen samsung TV…a brand new Samsung tablet. And I can’t cast the screen? Like many others have said, that is one of THE MAIN REASONS I bought the thing.

My tab7 works just fine.

That’s just mind-boggling.

And the recommendation to get a chrome cast really annoys me.

I guess the ‘smart TV’ really is not that smart.


The new app works perfectly. As stated earlier, download it from the galaxy store…it even has a cool feature where you just tap the phone on the TV. SWEET!

I’ve been using an old Android v7 smartphone running SmartThings for a specific use case, but it’s no longer usable. I’m looking at the Samsung Galaxy Tab A7 Lite 8.7 which has 3GB of RAM, but I see a post above that the A7 is not compatible. I read on Samsung’s message board that a person wasn’t able to install SmartThings from the Google Play store since it said it wasn’t compatible, but the person was able to install SmartThings from the Galaxy store. Worst case I’d think SmartThings could be side-loaded.

Anyone here running SmartThings on the new (2021 July released model) Galaxy Tab A7 Lite 8.7?

Update: I purchased the Galaxy Tab A7 Lite 8.7 64gb model for $150 from BestBuy which has 4gb of RAM instead of the 32gb model with 3gb of RAM. SmartThings was available in the Samsung Galaxy app store and runs fine. The only drawback is that Samsung doesn’t allow installing their Good Lock features onto this Android 11/One UI 3.1 tablet.

UPDATE: As for Good Lock on various Samsung devices, it requires One UI, not One UI Core which is on the Tab A7 Lite I purchased. Wow, fragmentation in their own products as there is One UI, and then there is something else called One UI Core. Go figure.