SmartThings Community

Smartthings classic can't log in


(Daniel Consuegra) #1

I’m temporarily using an old Samsung Note (N7000) with android 4.1.2 installed.

I’ve been able to install the ST classic app.

I know that my password is correct… as is my email…

But still I can’t log in… any ideas?


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #2

What error do you get?

Both the Classic App and new App require jumping to default browser, which must by Chrome or the Samsung Browser in order to complete authentication; that’s why SmartThings App does not work on Amazon Fire HD Tablets.

I presume that either the above requirement or some other App requirement is simply not compatible with such an old version of Android.

Major “Android Webview” stuff changed around Android v4.3 / v4.4 / v4.5 … any many other changes after that too, of course.


(Steve Jackson) #3

I found this (it says Android 5.0 for phone or 4.1 for tablets) and I think it applies to the old app as the new app says it requires Android 6.0.


(Daniel Consuegra) #4

I get an error about incorrect email or password… (10+ times incorrectly? seriously? lol!)

I installed Chrome right after reading this and nope… same thing…

So I guess it’s a matter of compatibility… oh well… Thanks guys!


(Alex Kum) #5

Im not able to login if connected to wifi. However it is working if connected to telco 4g directly. Since smart connect taken over the previous smartthings app (now is called smartthings classic), all kind of weird stuff happening at smart connect. Im reluctant to use the new app as it didnt correctly recognise all my devices. I deleted some unknown device in smartconnect (more than 200 unknown devices) then I realised my yale zwave lock and xiaomi motion sensor has been removed from my list of devices in my old smartthing app aka smartthings classic. I verified list if devices is missing through the smartthings web portal. Please explain this shit causing me alot of incovenient.


(Daniel Consuegra) #6

UPDATE: changed over to a Nexus 5 with the latest possible updates to the OS and everything works… will have to keep the Note as a micro tablet for actiontiles when I get around to purchasing it… lol!


(Terry) #7

Hi guys I’m having an issue with my smartthings classic app. My Smartthings Classic app will no longer login. I am in a perpetual loop. When I open the app I get a screen, new user or existing, click existing, enter email, opens browser, asks if I agree, takes me to the app, two seconds later the whole process starts again!

I am using a Moto G5 Plus and it’s been fine for over a year. I reinstalled the app and that seems to have kicked me out. My account and the app works on my iPhone and Samsung tablet A8. I just installed it on my Samsung A10 and the same loop and login issues exist. Seems like new installations causes it.

Any thoughts?


(jkp) #8

Try clicking on new user and then select Samsung or SmartThings account to login :slight_smile:


(Terry) #9

Just tried…nope didn’t work. :thinking: Puts me back into the same loop.


(jkp) #10

Try clearing the cache for the app in settings


(Terry) #11

Thanks. Tried that. Got a bit excited cause it actually loaded for a second then baam…straight back to the login screen again. Any more ideas?


(jkp) #12

can you login with the STSC app?


(Terry) #13

Yup no issues logging in with the ST app. Just the classic. Again, I’ve been using classic with no issues up until about 4 days ago. My presence sensor was playing up so I thought I’d uninstall and reinstall. That’s when I had issues logging in.


(Mike Debney) #14

I’ve had the same problem for ~a week now. Submitted a support request 4 days ago, still received no response. One time after clearing the app cache and logging in as a “new user”, the SHM and favourites list worked for approx 30 seconds before logging me back out again. I can log into the web ide ok however.


(Ariva nanthan) #15

I am also facing the same issue for a week now with no response from support…


(ocpd+adhd+alz+md+hfa+fms+lol=me :)) #16

I’m now having the same problem on one of my client’s phones, trying to log into their account.

Android 5.1 on an older generation Motorola Moto G
Latest version of ST Classic.

They hadn’t used it for a while.
Just got back to it today.

I sat right here and watched them walk through the process of changing over to using their Samsung account instead of their SmartThings account to log in (which was a PITA in and of itself).

They enter the credentials for their Samsung account in the SmartThings Classic login screen, and click ‘Log In’, but it says,
“Incorrect email or password”.

What am I doing wrong? lol

NOTE: We know the credentials are correct; they even work to log into the IDE (which shows that their account was indeed changed over to using their Samsung account).


(jkp) #17

try selecting New to SmartThings and then use their Samsung account to login


(ocpd+adhd+alz+md+hfa+fms+lol=me :)) #18

Doh!
Thanks. That worked. :confused: :slight_smile: