SmartThings Classic App 2.17 Presence Sensor

Hello I currently use a Samsung S10 and primarily using ST Classic App version 2.17
I just noticed recently that my hub will show that I have arrived home but then it changes to Away. Then some time after…it will show that I have arrived home again.

I’ve taken notice of this alot more lately. It consistently does this
Then arrived

I have unplugged my Hub and plugged back in as well as Re-installing ST Classic Ap 2.17

It doesn’t seem to correct itself.

Any tips on how to rectify this?

thankyou in advance.

Make sure your phone isn’t doing anything funky with it’s location.

Make sure your phone isn’t doing anything funky with WiFi connectivity to your home network (may be more of an issue with the new app).

Increase ST’s geofence area, and/or the presence timeout value in the IDE -> Utilities

Upgrade to the newest Classic release (should have fixed issues with missing icons).

Since you have an S10, I suspect you have the new app installed but not configured? Just make sure presence isn’t set up. You could also set up presence in the new app and not in Classic. I did that and it works fine. The mobile phones still show up in the Classic app as well.

1 Like

johnconstantelo thanks for the tips. This is what I did since reading your reply

  • phone is connected to Mobile Data when this occurs. I’ve checked Location in Phone settings and everything looks Spot On
    -Increase ST Geo Fencing or Presence TimeOut - I logged in the IDE Utilities and couldn’t find the location when make those changes when I logged in.
    -Upgrading to Newest Classic. I currently have 2.17 version. I remember the newer versions right after 2.17 had problems with Presence AND the icons. I will update it now
    -Yes I have an S10 and New APP is installed and yes I had the presence sensor working in the New APP. I went in the IDE Utilities and deleted the Presence sensor for the New App.

To access the utilities, you login to IDE, select the menu hamburger button in the top right, select Hubs, scroll down to Utilities and select View Utilities. There you can adjust your presence timeout. Also great to know that this is where you can reboot your hub and issue a zwave network repair.

Secondly, did you turn off the geolocation in the new app?

saosinx88 thankyou for the reply
I accessed utilities and viewed utilities Presence Timeout Says 2 minutes. Should I change the value?
I openned the ST NEW app and CONFIRMED the Location Setting is OFF
ST NEW app is version 1.7.47-22 should I update to the LATEST version?
ST CLASSIC app is 2.17 should I update to the LATEST version?

thankyou in advance

That’s the up to date for the new app, but definitely update the old to 2.19.1

Correction typo
my current version ST NEW App is 1.7.42-22 / Should I update to the Latest?
Okay ST CLASSIC I will update to 2.19.1

What about the Presence Timeout value setting? Should I leave it at the 2 minutes or Increase/Decrease?

thankyou in advance

Increasing the presence timeout will certainly help with false changes. And though I don’t think the newest update had any changes with presence, I would still recommend keeping it up to date. There’s a lot of changes happening right now with the push to get everyone over to the new app and newer features are added frequently. Is there a reason you don’t want to use location in the new app? We use Life 360 for presence and it is flawless.

I guess it’s tough for me to change over…
I got sooo used to ST Classic
Also I got tired of the problems of the Update right after 2.17, which is why I stayed with ST Classic 2.17 and turned Off automatic updates

I guess Now is the time I should make the switch to the New App ? Ditch the ST Classic App?

I personally have switched over everything possible to the new app. It has come a very long way in the last few months. We have over 100 devices and just about everything is working really well.

ok will do then. I’ll make the change when I get home this evening. Thankyou for all the responses. I appreciate it.

1 Like