Smartthings Classic and Smartthings (Samsung Connect) dashboard doesn't update when arming home

I have an ADT Smartthings security hub with 3 door sensors, 2 motion detectors and one Key Fob.

The setup has been running with no issues since January 2018.

Today, I noticed that Smartthings Classic dashboard doesn’t update when I arm the home manually via my ADT smart hub panel (everything is grayed out on the dashboard). Also, I can’t disarm the alarm via the Smartthings Classic APP either since the dashboard is not updated. I tried downloading the Smartthings Samsug Connect APP as well but the dashboard is grayed out here as well. This is happening on my Iphone as well as on my Android phone.

I confirmed that I am running the latest firmware version on my ADT smart hub

Has anyone experienced this issue before?

Do I have to factory reset the ADT hub and sync up all sensors again from scratch.

Any help would be appreciated.

  1. The ADT functions are not yet compatible with the SmartThings (Samsung Connect) App as far as I know. Please continue to use only the SmartThings Classic App.

  2. Using the new App sometimes / often creates a secondary new mostly empty SmartThings Location, which becomes the default. You can confirm and fix this in the IDE under My Locations at

Drill into the Locations, determine which is the correct one; mark it as “default”, and delete the other one.


Thanks for the reply, I confirmed that I only have one location setup under My Locations. What’s strange is that when I start up the Smartthings classic APP, the dashboard doesn’t show that my security system is armed even though I have armed the home manually via the ADT panel. Not sure what might be causing this display issue. I confirmed that I can arm the home vis the APP but the classuc APP never show the armed status on the dashboard.

The Smart Home Monitor dashboard solution SmartApp (inside the SmartThings Classic App) is 100% distinct from the ADT Alarm arm/disarm dashboard solution module… isn’t it?

I’m not sure familiar with ADT, so that’s why I’m not speaking with certainty; but I didn’t think they were coordinated.

And maybe that’s not the problem you’re expressing. It’s just that terminology is confusing when there’s more than one SHM and what do you really call the ADT Solution Integration module?

I was able to fix this APP dashboard display issue today.

If anyone runs into the same Smartthings classic display issue, you can fix it by remotely resetting the ADT Smartthings security hub using the below procedure.

In your browser, go to
Click Log in
Enter your SmartThings account credentials (email and password)
Click Log in
Click My Hubs
Scroll down to Utilities and click View Utilities
Under Hub Commands, click Reboot Hub

1 Like

Had the same issue. Rebooted and it works fine now.

I bought the Samsung ADT Smartthings kit over Holidays and installed it. I went through a lot of pain getting everything to work correctly as well. The hub install, registration and sensor pairing worked flawlessly.
However, the ADT Dashboardin the Smartthings Connect app did not register any of the ADT-compatible sensors.

To resolve the issue I had to do a factory reset of the hub. This requires removal of the hub from the Connect app, removal of power and the battery backup in the Hub. Then restarting of the hub, registration of the Hub then re-paring of the sensors. I thought everything was working…but…then realized I could arm the hub (stay or away) from the ADT dash board, the hub would arm , the dashboard would give me a spinning circle indicating something was working, but, then the Dashboard would revert to report ready for arming after about 30 seconds. Additionally the ADT panel would turn gray; but the Hub would arm. When this happens you cant disarm the Hub from the Connect App because the App believes the Hub is not armed. I did a number of hub reboots, installing and removing of the app etc. No luck.

To finally resolve this issue I had to do another factory reset of the hub and everything that goes with that.

I am happy to report everything now works correctly.

  • Mike