SmartThings + Arlo - seriously, what is going on with this integration lately?

What is going on with the SmartThings + Arlo integration lately? It hardly seems to be “integrated” at all these days.

There are significant lag times between a motion sensor connected to SmartThings detecting motion and then triggering an Arlo cam to record the scene. Arlo Pro cams seem to trigger slightly quicker, but still with a noticeable delay. This supposed integration between SmartThings and Arlo is rendered useless due to the fact that the cameras are triggered to record after too long a delay and therefore completely fail to actually record what triggered the motion in the first place. How is that deemed to be a good integration and a good security solution? I’m certainly not the only person to have noticed this; just google “smartthings and arlo” and there are several forum and community posts regarding these unacceptable lag times already.

It never used to be this poor. My SmartThings / Ring Video Doorbell / Arlo integration used to perform so well. The Ring Video Doorbell would detect motion at my front door, and SmartThings custom rules would trigger 2 Arlo cams in the same area to record within 1-2 seconds, sometimes quicker than that. This would mean a postman posting mail through my front door would trigger motion on the Ring Video Doorbell and the 2 Arlo cams would both successfully record clips of him doing the same, from 2 different locations and angles.

Recently, I’m lucky if either of the Arlo cams recorded clips capture the postman in the area at all, due to the delay in triggering the cams to record, as he has already left the monitored area. How is this regarded as acceptable? When the so-called integration performs this poorly, it totally negates the benefits that such a security / monitoring solution should deliver.

Even more recently, viewing the Arlo cam live streams within the SmartThings (Android) app seems to now be broken. It either gives a “Could not Start LiveStream” or “Camera unavailable” message in the video window in the SmartThings app, despite viewing the live streams in the native Arlo (Android) app working perfectly well.

My Arlo Base Station is within ~10 feet of both my Arlo Cams, and also connected directly to my router, which the SmartThings (v2) hub is directly connected to as well. Both Arlo cams are reported as having strong, stable wireless connections (3 bars) to the Arlo Base Station in both the SmartThings and Arlo apps, so I’m ruling out any connectivity issues, especially as this setup worked so well months ago.

What has changed with this integration in the last few months? It was such a good integration when it worked, and I really loved how it worked almost flawlessly. Now, it’s just frustrating, compounded by the fact that my setup hasn’t changed at all in all that time. My settings, rules, device locations and connectivity are all the same, so something must have changed either on the SmartThings side or the Arlo side. I know I am not the only one frustrated by this.

Can anyone from SmartThings - please - throw any light on this? It is almost sending me insane… :slight_smile:

Many thanks in advance,


I would like to know also what’s going on with arlo & smart things? I’m looking to purchase the arlo pro but so far it has been nothing but issues. I just had installed a ring doorbell pro & no complaints, their customer service is very responsive to. I have not heard the same about arlo/netgear.

Agree with OP. There’s a 10-15 second delay between the initial motion detection event and when SmartThings performs an action based on that motion detection (in my case, turns on the outside lights right next to the Arlo Pro). It used to be less than a second.

The Arlo integration is poor at best. There’s an “outage” right now even on live feed and recording according to the status page:

Who knows when it will be resolved…

The only way I have gotten my Arlo Pro to be useful at all with Smartthings is to add them to Smartthings and then switch the mode back to “Armed” with the Arlo app and actually delete the Smartthings mode completely. I then use Smartthings to just turn on/off cameras as needed but they’re always “Armed”. Smartthings does seem to be able to tell Arlo to record the 2 minute clip as per the home security app.

As for the Smartthings delay, you may have better luck with an IFTTT applet. They have an official channel and response may be more reliable than the Arlo/ST link if they’re having this much integration issues.

There is a known problem with Arlo right now and some staff discussion of it in the following thread:

Hah, nice. Just bought an Arlo Pro today (Yes I am aware of the 2’s release) and couldn’t get a stream to work through smartthings. I guess i’ll see how it goes once this outage is over.

The past week, perhaps a little longer, my Arlo Pro integration with SmartThings has been hosed. I was using the Android widget to Arm and disarm the cameras (my only using the Armed Mode in the Arlo Pro, and having SmartThings simply turn the cameras off and on. I did it this was as the original SmartThings mode for the Arlo Pro was seriously flawed).

The widget stopped working with Arlo Pro completely, and the SmartThings dashboard will “arm” the cameras in Armed Mode, but will not turn them off with Disarm. I have to now go into the Arlo mobile app and manually switch modes to turn them off and on. Sucks, as this was part of my home security system and other sensors for the door and motion.

I have given up. I deleted the Arlo integration in ST. I arm & disarm the cameras using IFTTT and a virtual switch in ST.

As mentioned in today’s update, I was given the “Re-Authorize Connection to Arlo” prompt in the app. My rules / routines for when to turn off/on cameras are working again! Hope its back to normal for others, this was frustrating!

1 Like

I finally got a response from Netgear that these problems are known and they are working on them. I found that everytime I used ST to turn off a camera, the camera would lose it’s connection and I would have to re-pair it to the hub.

1 Like

Hello all,

I use springify. It WORKS!!!
Arlo - smarthings connection issues have been driving me crazy. I had the rule set up in smarthings that said when the mode is away and if the front door opens, record the front camera. The rule worked but no clips were generated. I realized you can always go in to Arlo to see if the clips were there. Some times, the clips were in arlo, sometimes not.
I used IFTTT, but this is limited in scope. You cannot have multiple triggers.
This is where springify comes into play. Its like IFTTT, but you can create multiple triggers for an action. I have the same rule written in springify and when ever the criterian is met, clips are generated. You still have to open the arlo app to see the clips. But its always there.

You mean stringify, right? Not “springify” unless that’s something new.