SmartThings app with Apple iOS device receive error when try to download controller

Hi,
Ive been chasing Samsung support for few weeks, so far going no where. i thought this might be the place to raise my problem, seeking for assistance

I bought few weeks ago SmartThings Hub V3 in UK through Amazon and download the latest smarthing app, I’m using Hue and other smart apps however when I try to download the controller by clicking the boxes, i get a message “Couldnt download controller for …please try again later”
The only controller i have so far is for my Samsung TV, all the rest (sensor, lights, Hue etc) getting the same message.
I’m using iPhone XS Max with ios version 13.1.13
Smartthing app latest version 1.6.39-337

I tried several directions with different configurations mostly trial and error approach, non of those ways brought me further, here are some of them

  • restarted the HUB and installed it from scratch
  • Tried to install the app on other mobile device (IOS and Android) to see if i can download controllers through other devices - didn’t work
  • Checked thh versions and latest SW updates on both HUB and IOs device
  • Checked latest Firmware HUB updates
  • checked if Geo location is causing it by disabling and enabling location service
  • removed cache and history
  • Unlinked Alexa setting
  • Unliked HUE philips setting
  • Removed other connected devices (as my Samsung TV) or the mulipropose sensor, smart button and motion sensor
  • Tried to connect through 3G
  • Tried to connect with other wifi
  • resting my password account
  • and more…

Non of them worked really, i was expecting a better Samsung service specially since this is a new product that i bought last month…i might be wrong?

Thanks

Can you post some screenshots for what you are trying to do? I guess I am confused when you say download the controller by clicking the boxes. Can you be more specific what you are trying to install?

Can you provide the model number for the hub? I see you posted v3 but you also posted v2 in the tag in the title.

1 Like

@yooc, You can try to update SmartThings to the latest version. It looks like there is a new version.

image0

@GSzabados Im using 1.6.42 already, same issue

“Clicking the boxes” i meant click the “boxes” within the app per each new device that i added, once i do that i receive a a message “Title:Download device controller?” content: to use all the features of this device, a controller needs to be dl" when i click “download” button i recieve the same message “coulnd download controller for…” for few seconds then nothing happens
I got the same message for every device im trying except for my TV (Samsung) which was added properly
see examples bellow attached

On your iOS device, go to Settings > Cellular and at the bottom of the screen, make sure SmartThings is enabled.

If it is enabled already, you can try removing the ST app and perform a fresh install. If still not working, you can reset the network settings on your iOS device.

@jkp tried it, didnt work. thanks for the support

Contact ST support and let them look into this. Please report back if they resolve it for you. :slight_smile:

You can reach them by clicking on the menu (three bars in the upper left of the screen) and selecting Help.

will do :face_with_head_bandage:request was submitted mid of december 2019 nothing so far

Another thought…

Try rebooting your hub through IDE at https://account.smartthings.com choose Hubs in the menu and then click on Utilities to find the reboot command. Probably will not solve your issue but worth trying.

Hopefully support will contact you soon.

@yooc did you get this resolved?

Not yet, very lame customer support, so far suggested very basic troubleshooting

Do you have any ad blocker or malware apps installed? If yes, disable them and see if everything works in the new ST app.

I found that if I install the app on other iPhone (not mine) it does work, but other my mobiles (with my apple account) simply doesn’t work, I guess it’s something with my apple account configuration, but I have no idea why

Found the solution myself, apparently you need to take out the SIM card then the controllers appear with no issues, once you get for the first time all the controllers you can bring back the SIM card. Very odd solution but it works.