Smartthings app says that I need a hub to connect to device when it shouldn't (27 Oct 23)

Device is a Sengled Bulb model W31-N11.
I have a pair of Sengled bulbs that were initially connected to my account, but I disconnected from the account by disabling the Sengled linked service. I wanted to reconnect the app to the bulbs, but the app spits out an error when trying to add the device stating I need a hub. I didn’t have a hub before and I checked the supported devices list for my device and it says a hub was not required. How do I add these bulbs? I shouldn’t need to get a hub for this.

Since these are WiFi devices so you don’t need a hub.

Install bulbs in Sengled App. In SmartThings go to add device (+) > partner devices > Sengled > view linked service.

1 Like

The view linked service option does not seem to appear at all. All I can see is a list of device types and the matter option. When I select “Lighting”, it states that I need to link my sengled account. I then select next, and after a second, an error pops up and states that I need a hub to connect. This is before I can even link my account. Error code is 34-000.

can you post screenshots of the path/process you are taking?

Sengled has both Zigbee models (which need a hub) and WiFi devices (which don’t, and should appear once you have added sengled as a linked service).

They recently changed the navigation, and I personally find it really confusing, but here’s what works for me:

  1. from the main screen in the smartthings app, click on the +.

  2. choose “add a device“ (not “add a service“)

  1. on the next screen, choose “partner devices”

  1. this brings up a list of company names. Find sengled and tap on it.

  1. this brings up a page about sengled. It’s really important that you DON’T select “connect directly“ or it will take you to the page that tells you you need a hub. Instead, just tap on “next“ at the bottom of the page.

  1. that should take you to the page where you can sign into your sengled account.

  1. if you are in step five, and you don’t see “next“ at the bottom of the page, It thinks you are already linked to sengled even if you never have. In that case, tap on “view linked service” instead, and again, it should take you to the sign in page.

Your screens may look different than mine if you are on a different kind of mobile device, but the process should be the same.

As I mentioned, I find this whole navigation flow confusing, but it does seem to work.

Are you able to get through these steps and if not, where does it fail for you?


After 4, I see this screen instead.

Once I select Lighting, I get a different screen stating that I need to link an account. Afterwards, I get an error.

I can’t include more screenshots since I am new here.

After 4, I see this screen instead.

What brand/model mobile device are you using? (Mine is an iPad)

It might be a problem with the newest android app. :thinking:

But if all you did was click on “add“ in step three, it shouldn’t have taken you directly to a sengled screen, did you tap on something else first?

I can get to the screen you show if I click on “view supported devices“ or “connect directly“ – – both of those take you to the options for the Zigbee models, which do require a hub.

But if I only tap on the “view linked services” at the bottom of the page, that takes me to the sengled sign in for the Wi-Fi models.


It is a Galaxy Z Fold 3.
My flow was add>partner devices>sengled, and I see the devices list.

View linked services is not a button that exists for me.
I get this instead:

Afterwards, I get the error after selecting next.

Are you clicking the “Next” at the bottom of that screen? For me, that takes me to the sengled sign in screen. (Again, don’t tap on the blue “directly“ link – – that’s for the Zigbee or Matter models.)

This is what I get after selecting next:

Hmmmm…never seen that one before!

I think you’re going to have to open a support ticket by contacting smartthings via either email or phone:

Having nothing better to do, I just played with this (I don’t have any Sengled devices). I found that choosing ‘Sengled’ brought up the device type page. If you choose anything but ‘Lighting’ you go straight to a hub selection screen and only if you go to ‘Lighting’ do you see the screen mentioning linking services. When you hit ‘Next’ it says it is downloading setup data but then switches to the hub selection screen anyway.

So basically I see what the OP sees but I don’t get the error because I have hubs.

I couldn’t find a flow that allowed for creating the linked service.


Were you using iOS or Android? If android, was it a Galaxy device?

I’m in the US, using iOS on an iPad, which is why I think I’m seeing something different even though I, too, don’t have a hub. :thinking:

I was using a Galaxy and another Android phone.

1 Like

hey guys, I am having a similar issue trying to add Sengled WiFi bulbs, when I reach that step and click NEXT I am not able to choose what kind of bulb want to add (Zigbee or Wifi), ask for a QR Code, I click SKIP and says " Prepare your device, install and power on the light" then it gets stuck. Eventually it will end with an Error Code. I am not able to link my Sengled account with my smartthings account (like it was working before), the option is simply not there anymore. I am using latest firmware .50 and latest ST app (1.8.09) in Android

click on the first Next after you select to Add Sengled. I believe you are choosing Add Sengled and then “you can connect devices to SmartThings directly” and then clicking Next. so if that is the case - click the Next on the previous screen.

The new UI is going to drive users crazy! just saying.

This is the page many of us get when we choose ‘Add Sengled’ …

The page you describe appears if you choose ‘Lighting’ from the above screen.

If you choose ‘Next’ you get …

If you have a hub that redirects to the hub selection page if you have multiple hubs or straight to the QR scan otherwise. If you don’t you get an error.

If you choose the ‘directly’ link on the previous page, or one of the other device types prior to that, you get the hub selection/QR page immediately…


Did it, same result, when I want to add Sengled, only options either scanning a QR code or scanning is available. I do not reach the login page for Sengled. Funny, same thing happening when I try to add Ewelink. Phillis Hue and TP-link Kasa worked flawlessly.

YES, that’s correct