Smartthings App on my Android (Samsung) phone not working

I have previously installed the Smartthings hub, downloaded the app and set up my devices and automation and it was all working OK. Now when I go to the app on my phone, the app seems to be there but I cannot see the hub or devices. It seems that there is no hub or devices. Yet I can still control devices via Alexa. Any ideas would be appreciated. Thanks

You may have a 2nd Home (phantom) Location that was added as a result of installing and logging into the NEW SmartThings app at some point. Just a guess.

If you are using the SmartThings Classic app then you need to go-to the Dashboard page, press the 3 Horizontal bars (upper left), then click on the down arrow for the location drop-down and select the other Location in the drop down.

If above is the issue, then you can permanently remove the bogus Home location by following the steps in the post below:

Thanks to all for the comments received - much appreciated!

When I try to log in to the IDE here’s what I get:

Using these tools you can manage your hubs and devices, give them unique names, and organize them into locations and groups.
Access your developer tools: create your own apps, create your own device types, view your logs, and access developer documentation.

Where do I go from there?

There seems to be only one location (called Home).

I’m trying hard to get my system back without having to set up my devices again. Since the devices can be controlled via Alexa, I assume the device setups in Smartthings are still there - But I can’t see or control them via my phone app or through IDE. It’s like everything disappeared but it’s still there in the background somewhere. How do I get it back (very frustrating!) I spoke to someone at Smartthings on Friday but he couldn’t help much… He said because I’m linked to the Alexa App then everything has to be done through the Alexa App… and the ST App is no longer active. That doesn’t sound right since I don’t believe you can set up new devices (i.e. Z-wave switches) through the Alexa App.

Any other comments/suggestions would be greatly appreciated.


Please provide screenshots of the ST app and what you are or aren’t seeing.

Back on the IDE, when you went to the Locations Page, when you select the Location name (Home), then scroll down to Hubs, does it show your Hub?

Thanks for your comments WB70.

In the IDE, when I click on Locations, 2 locations are listed - one is called Home and one Robert. I don’t know why there’s two. When I click on Devices, it indicates "no devices found " for each location.

When I click on “My Hubs”, it says “You don’t have any hubs yet. Please use the SmartThings mobile app to claim your hub.” - Not a very clear statement, although I tried but nothing became of it.

When I click on My SmartApps, it says “You don’t have any apps yet. Add one now.”

Does any of this give any clues?

It seems that my system exists somewhere (because I have access to it through Alexa, But I can’t find it anywhere not in the IDE nor the Smartthings Apps.

Any other comments/suggestions would be greatly appreciated.


When you are talking about Alexa, are you positive that the devices you are referencing to Alexa are SmartThings discovered devices? Can you tell me a make and model of a device that Alexa is successfully able to execute on? Just trying to make sure it’s a device that would only be in ST that was discovered by Alexa and not some other device.

I personally would get in touch with Support and not mess with anything. Especially having a Location named Robert tells me that you had an actual Location with a Hub at some point. Explain to them about both Locations in the IDE and I’m sure they will be able to repoint everything correctly on your account.

Alexa can control many Z-wave switches that control lights. I believe these can only be controlled via the Smartthings hub since I have no other Z-wave controller.

This thing is testing my loyalty to Smartthings…although I do like it and want to get it working again.

Any other comments/suggestions would be greatly appreciated.

As I stated above. Leave it totally alone and create a ticket with Support so they can help you out.

This isn’t a problem the community will be able to help with. The fact that you can login successfully and the fact that you have a Location called Robert, yet no Hub is found, this is something that Support has to look at. We have seen a few people with weird issues like this and they had support resolve it. More than likely the pointers to your shard are screwed up on the backend.

You reported this same error in August 2017.


Thanks again WB70. I will follow that advice. As I mentioned above, I did call Samsung last Friday (Apr 13, 2018) and the person I spoke to wasn’t very helpful…but I will try again. The number I called was1-800-726-7864. It seems to be a general Samsung support number, with many support options, none of which mentions Smartthings directly. Is there a better way or different number to get to the Smartthings support people.

Best regards,