Can Not Set Default Location to True

Since the SmartThings Service and Developers have been unable to solve my problem for three months, I am coming in frustration to the community to see if someone has experienced my problem and has a solution.

The history of my problem is very long and a lot has been attempted, e.g. deleting and reentering locations dozens of times, resetting everything dozens of times, deinstalling and reinstalling apps dozens of times, etc. I will therefore keep my summary short and hope this contains enough information to identify the problem:

Summary: the new app does not see any active locations and devices, but the classic app (and IDE) does. We believe this is because we are unable to set the default location (or any location) to “true”. Since I have the newer WiFi hub combined with SmartThings, I am supposed to use the new app and will be forced to eventually migrate in any case, so I need to get the new app working.

Some details:

  • We migrated my account in April from Germany where I used to live to the U.S., since I was unable to add some devices that are not allowed in Europe (my real location is Florida). Everything in SmartThings except for these specific devices were working at the time. This problem began after the migration of the account to the U.S., even after deleting all devices and the location and starting from scratch many times. I double-checked with Samsung corporate and was assured that my account was properly migrated.
  • I do not wish to setup an alternative account, because I use my Samsung account intensively for Samsung Pay, etc. Do not suggest this as a solution.
  • The new app always requests that I save the WiFi hub to a room in a new location. Once doing this, it is not seen anymore in the app, basically vanishes. However, I can see the WiFi (only) hub in the menu panel after a day or two and then use Plume, but the SmartThings hub shows as offline (in the new app) and I am unable to add any devices. The WiFi hub shows only on the panel and not in the app itself.
  • I can create a location and add devices if I use the classic app instead. The SmartThings hub indicates online in that app. IDE reflects the classic app, but the new app is empty and does not show any locations entered using the classic app or IDE.
  • The very patient person helping me on the service line also thinks the problem may be caused by the fact that we are unable to set the default location to true. No matter what we do and edit my location, it always saves to false. We have tried many, many variations of locations and always have this problem.
  • SmartThings development can not find the problem

If anyone has an idea, I would appreciate it. I am headed back to Germany for a couple of months soon and need a solution before then. Otherwise, I will need to bite the bullet and install all devices using the classic app with the knowledge that I may have to reset everything in the future.

Thanks,
Mitch

I have a similar problem on my Android smartphone, the location sometimes starts by itselfs. Why?

I cannot set the default location flag either. I might have a similar issue, as I was set to GB region when my account was first created (I live in Seattle, WA). After finally getting my region changed, I’ve had a whole slew of issues. There seems to be some lingering data tying me to the GB region, and it prevents me from performing certain actions. I’ve open numerous tickets with Samsung, spent hours on phone calls and emails, and nothing has improved.

I am sorry to hear about your problem, but it sounds absolutely identical to mine. I am also sure that it is a problem with residual data in the Samsung account database, but I had corporate recheck the database and they did not find anything wrong. The strange thing is that they migrated my wife’s account as well, but that one does work, just that I can’t use hers for this installation.

I am not sure how we can directly communicate on this forum. I would like to get your contact details so that we can swap details. I have found someone on the Samsung support team that will help us if we can provide more examples and it would be great to work together.

Thanks,
Mitch

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.