Smartthings App not showing "Power Meter"

We have several GE 40 amp switches that have been working for 3-5 years. (Model :3031 / 3032) of the GE 14285.

The new Smart Things app is not populating the “Power Meter” on the device on the dashboard. The only way to see the draw is go into History and see the last reported value.

This is constant across 5 locations which all have the same SmartThings setup.

Check the device handler that’s being used by your device in the IDE.

The device handler is correct, install has been working for 3-4 years across 20 installs.

IDE Device Handler = Z-Wave Metering Switch

All stopped reporting properly moving to new SmartThings app.

The data is available under “history” but not on the Control tab.

Rboy, we have 5 hubs tied to your products, they work great, let us know if you see anything else?

I also opened an Issue under SmartThings on Github and recommended adding 3032 as device type. We have a mixed of the GE 14285’s as 3031 and 3032s. Same behavior on both.

Try to log out of your ST mobile app and log back in.

Alternatively try the Z-Wave Metering Switch Secure DTH

We tried all of that, experience is consistent across 7 different IOS devices. (iPhones and iPads).

Power draw only shows up in History. Power draw also does sucessfully export to InfluxDB and Grafana no issue. The application simply will not display it.

Try to delete/remove a device and add it again.

The GW seems really dodgy there, but it supposedly correct. 2,000 Watt(W)= 2 kiloWatt(kW) = 0.002 MegaWatt (MW) = 0.000002 GigaWatt (GW) ~ 0.0 GW.

Not sure how or why that would help. We are seeing the data in the “history”, and we did attempt this at one of the properties. These are systems setup 100 miles from our office and the labor effort to delete/remove would take two full days of one of my techs go to all of our clients. This very much seems like an issue with the iOS app and not at a device handler or pairing issue. Flagging the attention of SmartThings / Samsung seems like the larger issue. It certainly is VERY repeatable.

This is a screenshot from a Zwave plug, which has Power Meter:

If the device pluggin has got something wrong, or capabilities has been messed up, the easiest way is to remove and add the device again, as that would refresh the whole UX.

Otherwise, as you are mentioning that it happens with multiple DHs makes me thing, that a specific Capability representation has got messed up, but as I have a plug with Power meter and I don’t have any issue, it makes me feel that somehow swapping the DHs has mixed it up. You can give a try on one plug at your office, if works, then that is the solution, if not then it must be fixed by ST.

I am tagging @Brad_ST and @dckirker, they might have some idea why your metering display showss GW - GigaWatt and not W or kW.

PS.: My device uses Z-Wave Metering Switch as well.

These are not “small plugs” they are 40 amp 240 volt systems controlling 3000-10,000 watts of heat cable on roofs of homes. They worked 100% until the migration to the new smart-things app. We unfortunately can’t get the attention of SmartThings to confirm if it is a IOS app bug. I do not have an android device to test that.

We remove and added one and it did not resolve the issue. That being said it would be two-three days of labor and driving around to multiple sites, not to mention getting in touch with each home owner.

It probably shows Gigawatt since these devices average over 1000 watts. We have one install with four of them totaling 7,500 watts, another with 12 of them running 74 amps at 17,500 watts…

I get your point, but it uses the same DH as any other plug with metering functionality. And honestly, for a task to handle this kind of plugs, I would never trust SmartThings. This system is a WIP - Work In Progress. Many features changes without announcements, features added and changes by force firmware and software updates, etc. It is not reliable enough for it.

You are still talking about kiloWatts, GigaWatt is a million (1000000) times a kiloWatt.

tumblr_mrpx6lArsf1sfjwwbo1_500


@prjct92eh2, can you check on your iPhone any metering plugs, do they show values at the metering part?

We are very aware that ST s a WIP, and the solution we have commercially in place is way more complex to type up in a forum. The abridge version is we use: http://www.loouq.com/ to do all of the control and sensors for IoT over a Verizon network. They are an industrial control company, however for residential application many owners wanted a dashboard with a secondary control.

The SmartThings integration is not the primary it is a backup for the clients to have a visual and built in with relays to override. The clients love it, LOOUQ saves them a lot of money, and we have had success for almost 5 years of doing control.

Back to the question at hand, how do we escalate this to ST to check the app? I am sure an engineer could debug this in about 30 minutes. Rather than throwing darts, lets get to a root cause analysis.

1 Like

I have already tagged a few people from ST and another person who can confirm if it is an iPhone display issue.

It is the weekend meanwhile. And I doubt that, if it is a genuine iPhone issue, then it will be resolved (generally) in a short time…
Definitely the GW shouldn’t be there. It should be W or kW.

Works fine for my old Iris plug

1 Like

Thanks!

It seems to be something special is going on. There are a few similar reports as @buster’s.

And

So there is definitely a bug in the app. Must be some clever solution again, and probably who coded it has no idea what is the difference between kW, MW and GW. (Like the temperature converter was recently.)

@Brad_ST, @dckirker, @steven.green, @jody.albritton

Can one of you have a look what is causing this GigaWatt flip over on the UI?

Hi

I’ve seen the same and reported it to Aeotec … who support is more responsive than ST by far but resolutions are just as bad … they totally skipped that point and just gave stock answers to repair the device. So if that’s a sign of things to come from the ST+Aeotec partnership I don’t think any future solutions are going to be any better than the unreliable ST platform is today.

So sorry no fix that I know but if you find one please do share .

I’ve now used simple event viewer into Google sheets to chart my data and that seems to work well. Once I’ve got it all working and tested I’ll publish the scripts and methods I’ve used .

Andy

Timely discussion. I noticed this on my gen1 HEM a couple weeks ago, and I changed nothing on my end, so I ignored it because this has happened before. Usually I see ST round to the nearest kw (1200 watts rounded to 1.2kw), but never gigawatts. This happens with both my own DTH and ST’s stock handler.

Can anyone confirm if the current “default” device handlers loaded on Samsung/ST servers matches the default one in the GitHUB repo? How often does ST refresh from GitHub?

Also, pulled an old iphone out with SmartThings classic on it. While it was brutal with all the pop ups, all devices are reporting properly into the SmartThings classic app.

I’ve managed to reproduce it (Android). It is definitely a bug in the app probably the UX plugin for the Power Meter capability representation.

I turned on a heater which has a decent power consumption.

And the Power Meter flips to GigaWatts…

1 Like

The displays in the new app are quite disconnected from the DHs. The displays in the new app are Capability representations. Some/most Capability has a representation on the UI/UX in a way how ST defined it. If some other way, differently should be the Capabilities represented then a vid can be created. It is all disconnected from the DH in that way, that the code for any representation is not coded in the DH but on the new SmartThings API and the list of Capabilities or a defined vid in the DH code assigns what should be visible in the new app.
In your case the DH code doesn’t make any difference, it is the Capability representation which has been screwed up.
Some reference to understand how the UI is working in the new app:

1 Like

And actually it turns back to Watts if the load is less than a kiloWatt.

1 Like