Aeotec Home Energy Meter ZW095-C

Hi, Hope everyone is well?

I’ve just purchased one of these to monitor my power consumption and feed the data into Grovesteams.

Had trouble installing it and had to use the Zwave tweaker to get the device to pair.

But now the problem I have is with the DTH. The device installs with the standard Aeon Energy Meter DTH (after changing from zwave tweaker) which does not work for the power meter and jumps to display GW with no data but does show the energy consumption

I have tried ClassicGOD DTH ( thank you for the work to create this) and this is better but still bombs out on the power meter , especially if you turn on a large draw object such as a cooker .

I’ve also tried the amend Tmp2k version of this DTH but I get worse result with no data at all then.

So question is does any one have a working DTH and any details on the best setting for the device as these are very confusing.

Any help is appreciated thank you


Yup, and I am having the same problem as well…

I have a similar problem with my Aeotec Zwave Heavy Duty Smart Switch (ZW078). It’s controling my eletric water heater. It draws around 4500 W but the SmartThing app shows it as 0 or 0.1 GW

Same issue, wattage looks to display correctly on Home screen nut device page on new app only displays voltage, meter and consumption are 0.0 and scaled too large (GWh/GW)…

App issue for sure as correct values are still being logged on “history tab”. seeing as a GW is a billion watts, i am guessing the 0.0 reading are accurate