SmartThings app fails to add new hub 2018

Hello, I’ve just got my SmartThings hub today, super keen to test this out. However my smartphone app won’t add it. It recognises the hub when i select auto detect, but every time i click on it, it fails.

I’ve tried restarting phone, uninstalling and re-installing app, clearing cache, force stop, tried resetting the hub even though it’s new…

I’m out of ideas. Any thoughts how I can get the darn thing to work?


EDIT - is there any way I can set up on PC etc?

Is this in the “new” smartthings app (has six circles) or the “classic” smartthings app (one large circle)?
I believe the new hubs need to be added in the new app and then you can revert back to the old app.

Wouldn’t be the first time I have been wrong though… ask my wife.

It’s the new app. Was actually already installed on my phone (galaxy S7) when I first looked for it.

instead of auto detect, have you tried selecting the SmartThigns brand and then the specific hub model?

Yes, tried that - it was under the Samsung brand though. When I do that, it just instantly fails.

Do you have a support ticket number? I looked for errors or a ticket but couldn’t find one.

No, I haven’t raised a ticket with official staff if that’s what you mean… More then happy to if you can show me where to do this.