Can't add SmartThings V3 (2018) hub to iOS SmartThings Connect app

I purchased the hub today and am trying to add it to the SmartThings Connect app. Just to be sure of the product I’m talking about, on the bottom of the device I have: M/N: IM6001-V3P01.

I am using an iPhone XS Max with iOS 12.1.4. The app I have downloaded is this one:

SmartThings (Samsung Connect) by Samsung Electronics CO.LTD.

I started the app and created an account without issue and verified my email address.

I clicked the “+” at the top of the page and then selected “Wi-Fi/Hub” within the “Samsung” category.

This is where I started to experience issues. On the resulting page, I have only the following two selections:

  • Samsung Connect Home
  • Samsung SmartThings Wifi

According to the Samsung support page at, I believe I should be seeing a selection for “SmartThings Hub (IM6001-V3)”. It is not there. How do I get that selection to appear? I deleted and reinstalled the app, as well as rebooted my phone without any change.

Attempting to select either of these two hub types and following the onscreen instructions exactly resulted in a page that says “Your Wi-Fi Hub isn’t ready yet. Wait for the LED to start blinking red and green, then try again.”

I repeated the attempt to connect the hub after resetting my cable modem and Wi-Fi router and attempting to plug the Ethernet cable directly into the router as well as directly into the cable modem, but there was no change and I cannot add the hub. I also tried adding the hub without the Ethernet cable connected at all, with the hub just a couple feet away from the router and my phone sitting directly next to the hub.

I also tried clicking the “Auto detect” link at the bottom of the “Add device” page in the app while the LED on the hub is flashing red and green and it times out and says it can’t find anything.

Is there anything I am doing incorrectly? I believe my issue is that “SmartThings Hub (IM6001-V3)” is not an item to select in my app, and I don’t know why it is missing. Is there perhaps an issue on the Samsung server side that will be resolved soon? Did my account somehow get created incorrectly?

I am in the USA and purchased the device in the USA from Fry’s Electronics.

Here are some images showing the hub box and screenshots of the app as I walked through the process of unsuccessfully attempting to add the hub.

I am going to contact Samsung Support in addition to making this post. If anyone has any advice on things I can attempt, please do let me know in the comments.

The “WiFi Hubs” are the hub models which are also Wi-Fi routers. Those are the ones that will work with auto detect.

What you have is the “V3” hub. Also called the 2018 model. It can connect to a Wi-Fi router via Wi-Fi, but it is not a Wi-Fi router itself. So you have been looking in the wrong device class. ( welcome to SmartThings! They tend to name a lot of stuff with very similar names.)

See the following official knowledgebase article for how to add the model that you have. ( for the models which are not also Wi-Fi routers, you were supposed to select the brand first and then you’ll get a different list of hub model numbers. Also note that as the knowledgebase article states, you need to select “SmartThings” as the brand, not “Samsung.”)

BTW, The article you linked to was on the UK site. (“GB” stands for Great Britain.") Not sure how you got there, but since you are in the US, use the US site instead.

Thanks! I managed to find the SmartThings Hub (IM6001-V3P)" within the SmartThings brand.

That is pretty confusing. I will try to add the hub again now. I really appreciate the assistance.


Can I ask you if you have solved?
I have the same problem and I’m going crazy!

Super confusing…You need to select the magnifying glass and search for smartthings. Once you find it, select it and you will see the hub as an option there. The rest is pretty easy.

I was able to solve the issue and got my hub added. Here is what I did:

  1. Click the ‘+’ at the top of the SmartThings Connect app.
  2. Select ‘Add device’.
  3. Scroll down to the ‘All brands’ section.
  4. Select ‘SmartThings’ from the list of brands. It is the very first one.
  5. Select ‘Wi-Fi/Hub’ from the list of device categories.
  6. Select ‘SmartThings Hub (IM6001-V3P)’ from the list of Wi-Fi/Hub devices.
  7. Follow the instructions to add your hub.

Here are screenshots showing the steps:

1 Like

For a company that is supposedly striving for ‘simple’, it is intriguing that a new user would have to refer to an online Knowledge Base in order to get the basic component of the system running.

Samsung has never been known for ease of use in its software. Just try explaining “home“ and “away“ and you can see they have continued this tradition. :wink:

Dear Dennis, I would thank you very much for your time spent to answer to me.
I live in Italy (where Smartthings is not launched officially).
Unfortunately, after selecting Wi-Fi/Hub from Smarthings I not see anything else of two items:


It may be that the app is detecting your location and limiting your choices since, as you said, SmartThings isn’t launched in Italy.

You might have success with a VPN that would geolocate you in the USA, but I’m not sure if that would work since I haven’t tried it.

I hope you get it to work.


Via Web( , create an UK Samsung account with country=UK (be careful change language bottom right from Italian-Italy to English, because otherwise it creates automatically an italian-Italy account).

login in the App whith the UK account.

Yes the registering process and selecting of Device needs to be a little more clear