Smartthings app Checking when on mobile data

Hi All,

I have noticed recently that when off WiFi and on mobile data the Smartthings app on most devices are saying “Checking” Its not an issue with my mobile data as it works fine with other apps and services, also my wifes phone does the same. We both have Google Pixel phones mines a 6 and hers is a 2 if it makes any difference.

I have tried to force close the app, uninstall and re-install the app. Log numerous calls with Samsung’s sport only to be told to upload the log which i have done.

Is anyone else experiencing the same of has a fix?


Do you use a SmartThings hub?

I assume you get the same issue when you are away from home?

You mentioned most devices say “Checking”… if you have a hub, are those directly connected devices (zigbee and z-wave)? Are the ones that do work… are they cloud-to-cloud devices?

Any VPNs or firewalls?

If you have a hub, Log in IDE at go to the Hubs section and see if your hub shows as active. LED color on hub?

It’s a Hub v3 sorry should have mentioned that.

I have a mixture of Zigbee and Zwave. Most devices are local (I do have some cloud devices, like Virtual Switches, which I’m not bothered about seeing when on mobile data). Just looking and my Front Door sensor for example is local (So the IDE states) but will show checking when Wi-Fi is off.


I don’t have any VPNs connected, or Firewalls as far as I’m aware, as i said it used to work before, so assume its app related?

Try rebooting your hub and router

One last thing… go to to see if your devices work there.

Do you have the most recent version of the ST app installed?

Already tried that, first thing I tried. Sorry its been on going for a while, and i have probably missed some steps I have taken.

As soon as im connected to any WiFi either at home or otherwise they refresh and load as normal.

From that link it shows fine

My app version on android is, it auto updates from the Play Store so can only assume its the latest.

This is the status from the Groove IDE

I believe you are seeing some sort of issue with the Android app…

Contact ST support to report the issue.

There is an open thread of recent android issues

Hopefully others might be able to offer more assistance or details

1 Like

I’ll chime in here, like @jkp said, its most likely the app. Ive been seeing this since I’m on a Note20 Ultra and wife is S22 Ultra, we see the same things.

Generally when on 5G opening/closing the app corrects it and sometimes it just takes a minute to load.

STHM in the last couple of days has also been sketchy when we come and go from the house together…not sure if your seeing this, but figured I would mention it.

We have found the problem, it seems my phone was routing through a different DNS provider (linked to a work app), which must have been slower to resolve.

Once switched off it works without any issues!