Smartthings app can not login on mobile network, works on wifi

I was trying to login over my mobile connection and was unable to login. The app would prompt me to login, direct me to the, I would enter credentials, click “sign in”, and it return to the app but would not log me in. If I tried to login again the would indicate I was already logged in and instead present a “continue” with current account button.

I tried all the things I could think of - enabling all cookies, clearing all cookies, reinstalling the app, trying both chrome and firefox, restarting the phone. It had been working the day before so I had a hard time believing it would suddenly stop. And my dog was lost just outside of a wilderness area so I was motivated to get it working so I could track him with the Smarttthings tracker. I could not get it working (but I did find the dog by passing messages between hikers and runners on the trail).

So I get home and try to login and it works immediately - no changes other than I’m on wifi. So I logout and try over mobile and it has the same problem as before. Try wifi and it works. This is fully reproducible. What could be causing this?

I’m on Pixel 4a running Android 11, Apr 5 security update. I’m not using any VPN or anything like that. I’m using a Verizon MVNO.

So I tried it with a VPN (Google One) - it has the same behavior.