SmartThings Community

Smartthings App always in notification


(Steven Lessard) #1

Hi all. First post. Liking my Smartthings home setup so far. Got a question about the Smartthings app (new not the classic). Anyways, on my Samsung Note9 phone, the Smartthings notification of “Smartthings needs to be able to run in the background to update the status of your connected devices” the it gives the option of Deny or OK. I select OK and the notice remains there no matter how many times I select the OK button. I have done the battery optimization as instructed in other posts.

Is this normal to have that notice all the time, and if not, how do I fix this?

Thanks…


(Eric) #2

seems normal if you don’t let it connect.

You can block those notifications at the phone, or exception-allow it to connect in background. In my Samsung it’s settings/ connections/ data-usage/ mobile-data/ allowAppWhileDataSaverOn/ etc.


(Steven Lessard) #3

I got that. I just need to know if there is an issue with this notice not seeming to work properly. The smartthings app seems to run correctly but the notice never goes away if if I “allow” the app to run in the background.


(Milton) #4

Hi, I have exactly the same issue.
For about a fortnight now I’ve had the constant message “SmartThings needs to be able to run in the background to update the status of your connected devices”.

I have the option of Deny or OK. Neither gets rid of the notification.


(David King) #5

If you turn off allow app to run in background via settings>connections>data usage, then click on the i icon to take you to the app turn off notifications and then turn them back. You can then go back and allow the app to run in the background without the notification popping up