Smartthings and Alexa voice control


(D B) #1

Alexa voice control seems to be unavailable for Smartthings virtual switches in the last few days.
I have a few smartthings GU10 bulbs which I have set up in groups, living room, bedroom etc. Up until recently I could voice command these virtual switches to turn the lights on or off via Alexa. Example being, Alexa switch on bedroom lights.

Since the 25th April, the virtual switches are showing as ‘offline’ in the Alexa app or PC dashboard. On voice commanding these ‘offline’ devices I receive the following message from Alexa; ‘sorry, bedroom lights isn’t responding’. I can, however, voice control individual lights via Alexa. The voice functionality was working for all devices including virtual switches prior to the 25th. Anyone else experience this problem?


(Ron Talley) #2

Delete them from the Alexa App. Go into the IDE, Location, Devices and update the devices. Tell Alexa to find new devices.


(D B) #3

Please explain what you mean by ‘update the devices’.


(Ron Talley) #4

Probably not necessary.

Click on Devices, then the Device, then edit, then update.

Again, this step is probably not necessary but worked for me. So when it works, I follow the same steps that got me out of that situation. Wife say’s I am so predictable…Welp, it is what it is. I keep drinking from the watering hole until it runs dry.


#5

Are these GU10 bulbs from Hue that are showing offline?

When you are viewing all of the devices in the Alexa App, are the offline ones referring to “SmartThings” at the bottom or specifically Hue (if these are Hue bulbs).

I had a couple of issues around both “Smarthings Devices” and “Hue” showing up as Offline. Go through your entire list of Hue Devices “whether it shows SmartThings or Hue”. After you have removed all of them, go click on your Hue Bridge Button and then click on Discover New Devices directly in Alexa (Don’t ask her). See if that brings the devices back into Alexa without the Offline appearing.

Perform the steps provided in the @rontalley post first and if that doesn’t work, try the steps above.


(D B) #6

Thanks @rontally and @WB70. I am still struggling with this issue.

I followed @rontalley’s steps and realised the following:

  1. The offline marker is removed from the virtual switch on the Alexa console
  2. The voice command issued to Alexa immediately after following the steps is successful
  3. Any subsequent voice commands fail.

I have also tried @WB70’s steps.

  1. All the devices are relisted on the Alexa console marked as ‘offline’
  2. Voice commands fail

Something must have changed in the past week or so as I have never experienced this issue.


#7

So I just went in and saw a few devices of mine that were offline in Alexa for SmartThings. I removed them, and then I DISABLED my SmartThings Skill from Alexa. I then attempted to ENABLE the SmartThings Skill again. When I did it opened the url for “https://graph.api.smartthings.com”, I then selected Location Lake House but there ARE NO Devices using that URL. My shard uses the “na02-useast1.api.smartthings.com”. LMAO - So now I can’t authorize any devices. WTF! LOL


#8

Disregard my last post. After Disabling / Enabling the Skill for SmartThings in Alexa (even though it didn’t list the devices when I selected my Location Lake House, I pressed Authorize and it added the Skill back in. I then went back and pressed Discover Devices. The Offline devices for SmartThings went away and I see all devices listed now (No more offline).

Before you do what I did, sort all your Devices by Name (Makes it easier) and then Remove all the Devices that say “Offline” that say SmartThings Device. Then Disable your SmartThings Skill from Alexa and then Enable the Skill which will make you log back into SmartThings and then Discover your Devices again.

Let me know if it works.


(D B) #9

Hi @WB70
That didn’t work.

  1. Removed the offline devices from Alexa
  2. Disabled Smartthings Skill from Alexa
  3. Enabled smartthings skill in Alexa and authorised. Signed into smartthings to continue
  4. Authorised Smartthings skill and rediscovered devices in Alexa
  5. The devices came back listed ‘offline’.

#10

If you login to IDE and then view your Hub. Scroll down to the bottom where it lists all of your devices under the Hub. Does the status column show Online for all of the devices that are showing Offline in Alexa?


(D B) #11

All the devices in showing as offline in Alexa are now showing as online in Smartthings. This wasn’t the case before. I had a few offline devices in Smartthings.

I got fed up and decided to create groups in Alexa to replace my virtual switches, which are now working very well.
I had to use different labels to the Smartthings virtual switches which are currently still not responding to Alexa voice commands.

Automation of lights and manual selection of the virtual switches works perfectly in Smartthings.