Alexa- SmartThings issues (Looking for possible solutions)

Hello all!! I have sent the below to amazon and SmartThings and just wanted to see your all’s thoughts (inc case there is a possible fix on my end).

Alexa can not communicate with “bedroom light”. As of this morning it has started saying “sorry Bedroom light isn’t responding”. When I go to look at the device in the Alexa app, it has a heading that says “the device is unresponsive”. I have checked and the physical switch works and also the SmartThings app works correctly. Also, this is the only device doing this within Alexa out of all of my smart devices. So I’m trying to figure out if something is happening when the information is getting transferred from SmartThings to Amazon.

Thank you all for any feedback!!

Had same problem with a couple of my things last night. Seemed to be working with alexa again this morning though. No idea why or what it was.


Hmmm. Thank you for the response. Mine is doing it as we speak :frowning:

I’ve seen this occur once or twice. What works for me in these circumstances is to reboot the ST hub.


That’s what I was thinking about. I shall give that a go.

What’s the device? If it’s a bulb, consider the possibility of a Zigbee mesh issue.

Unplug hub, wait for smartthings to report disconnected in smartthings app before plugging back in. A reboot from app or shard may not be long enough to register with echo. Rebooting echo may not be a bad idea either.

It’s a Ge z wave switch.

Do you have Device Health turned on? If so, you might try turning it off — a lot of folks find it is causing issues with Z-Wave devices…

1 Like

I have it off. I noticed I had to turn it back off after the last firmware update turned it on automatically.

That seems to have caused problems for some—me included!

SmartThings staff members posted previously that the Firmware upgrade wouldn’t have turned Device Health back on. It could have been from one of the mobile application updates in the last couple of weeks.

As for the Alexa issue, have you tried removing the device (Forget) from Alexa? Also, this device is listed only once in Alexa? If it’s a GE Switch, then I figure it was only discovered by Alexa via SmartThings.

Do this:

  1. Go into Alexa ( not from the Alexa application. If you do this from your phone, you have to switch to Desktop site.
  2. Forget the bedroom light and make sure there are no other previously defined devices (maybe you renamed in the past - Sort devices by Name).
  3. Then go into SmartThings and rename that switch to something like Bedroom Tester
  4. Discover devices again in Alexa and make sure that device name then shows up in Alexa.
  5. See it it responds to Bedroom Tester

Surprisingly the same result even after going through those steps.

When you edit the Device in Alexa,what does it show? I have a GE Smart Plug outside. I just added it to Alexa and she responded fine to it.

I know we are talking about different devices, but maybe it has something to do with how Alexa is recognizing it. Here is the device type being used by my GE Z-Wave Smart Plug / Module. Or a new Alexa issue :slight_smile:

Yeah I don’t get it. This thing has worked fine for 6+ months and all of the sudden this one device starts acting odd within Alexa.

I have the same thing with a GE dimmer, unresponsive in alexa, last time I had to change the device type in smart things and then set it back to get it to work, but that’s not working this time… seems like this may be an issue on their end


Same thing I also tried… Have you put in a ST ticket also?

Just did, I would think they would blame it on Alexa though.

Same thing I think too… And their customer support is terrible…

I found something odd though, if you could to the recently tab on the SmartThings request, all request create a line item through Alexa except for the offending device… Just seems odd. How could 1 device out of all of them do this?

What in the world… I just went back into the Alexa app this morning and the error has cleared… I bet anything it works now but no real explanation from anyone.

Hope it’s the same on your end!